Noob question-removing or extruding parts of a block

I want to do three things that I can’t, and I’m sure these are all really easy beginner things, but I haven’t found anywhere that can tell me how to do them. I have a rectangular block, and I want to:
1-remove one corner of this block, just a little square shape that I want to cut off there, but leaving the new exposed faces solid behind that.
2-divide one face into a series of different sized rectangles and extrude each of those out by a different amount.
3-draw a square in the middle of one face to extrude out.

ideally I need some way of drawing the shapes I want straight onto the block I have, dividing it up and manipulating those separate parts, but I can’t find such a function in the program. Just to complicate things, none of the divisions I want to make are regularly spaced or sized, so something like a subdivision or loop cut would not be very helpful. is there any other option?

OK, I’ve managed to shrink it in and re-extrude out to not include the corner I wanted to miss out, but now there are lines running across the block, how do I get rid of them?

have you read this? http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.63/BMesh

An example for the question 1
I press K (knife) then i cut like this , just cut it like you need to :
http://i.imgur.com/JlnpI.jpg

I press Enter or Space bar to validate the cut

I select the zone i just cut
http://i.imgur.com/vxFdN.jpg

I press Y to Split , and i press G then move it.
http://i.imgur.com/3IOyx.jpg

I select all the vertices along the hole left by the splitting then press F to create a face there
http://i.imgur.com/3CfeG.jpg

For the question 2, select a face and press the Subdivide button in the panel to your 3D View left. But the face needs to be a Quad for this to work, will not produce any squared result if used on a Triangle and will not produce any result if used in a N-gon face.
The subdivision of a quad face will produce many square (depending on the amount of subdivision set in the Operator menu.
The Operator menu is this that appear just after you press the Subdivide button (and disappear if you make another action modifying the model) :
http://i.imgur.com/LjhrG.jpg
It can be made appear as a popup window if you press F6

For the question 3, that’s again with the knife (K) that you’ll do something like this :
With your view perpendicular to that face (i mean the face you want to cut inside is exactly in front of your view), press C to “angle constraint” the knife.
http://i.imgur.com/8pJSH.jpg
Experiment with the knife function , it is very usefull.
edit : the Inset Function from Modron link could prove very usefull for your question 3 too.

OK, thank you, this is very useful. The trouble with the subdivide function is that I don’t want the face divided into equal parts, but I am sure I can manage to break it up just as I want with a little effort and patience. However, one issue I have found, when I am drawing out the shapes with the knife tool, how to I find out how long the lines are? I need to measure a certain distance across and down to one corner, then draw a square of a particular size from there.

Also, is there any way of stopping it making so many useless diagonal lines to every corner of the face I am drawing on?

This is really not looking good now
http://s1067.photobucket.com/albums/u437/Kitutal/blender/ :

Image 1-So I start with a basic block, managed to get this far at least

Image 2-I use the knife tool to draw a box, which of course is not quite square because I can’t find out how long each of the lines are to check. And this happens

Image 3-For some time, attempting to dissolve the unwanted lines just makes the areas around them darker, without affecting the actual shape of the block at all

Image 4-Somehow I manage to trick it into removing most of them, but a couple resolutely refuse to go anywhere

Image 5-When I then select the area I want to extrude up, it also selects the bottom face of the main block, for no apparent reason

Image 6-So, of course when I do extrude it up, this happens

What am I doing wrong here? :eek:

For your problem, i don’t think you’re actually doing anything wrong, you’re running in a limitation to the current implementation of Bmesh

To cut your square, do this cut first:
http://i.imgur.com/1H7vK.jpg

Press Enter/Space bar to validate the cut.

Then cut like this :
http://i.imgur.com/Hcezp.jpg
And validate with enter or space bar

Now in Face select mode , select the square that has been created and extrude it like you want
http://i.imgur.com/GbiJU.jpg

For cutting exactly a certain distance with the knife, i don’t think precision tools like in CAD programs are in Blender, i know there are addons that may provide something similar though but i never looked into it.

By default, measures in Blender are in Blender Units, in the 3D view while in Edit Mode you can access the panel to the right of the 3D View by pressing N , you’ll see the coordinates in Blender Units appear in the 1st tab “Transform” that gives the coordinate of a selected vertices, or an edge or a face.

You can change the Blender Units into another kind of measure from this panel :
http://i.imgur.com/tKHF0.jpg

By example i select meters

Then in the “N” panel, scroll down at Display and enable “Edge Length at numeric” so it displays
http://i.imgur.com/ZOczu.jpg
And as you see Blender will give you the exact measure of what you selected.

But as said, there’s no CAD tools available to change those measures easily, you’ll need to change the coordinates in the N -> Transform panel to get the distance you need for precision.

funny thing is, the measurements don’t make any sense, it’s giving the same length for three clearly totally different lines. A shame, because in every other way it’s a very nice, sensible and useful program
guess I’ll just have to push buttons until something works