Noob Question: Shading on UV textures

I am working on a project to display and animate some geological cross sections of Canada.

I have created some topographic models from DEMs and have mapped jpg textures to various surfaces, but I can not get those UV mapped textures to display shading. I get plenty of shading with material textures, but I am going to be needing to use UV textures.

I know the answer must be simple but I have done a lot of searching and reading with no luck so far

they should work fine unless youre using the game engine in which case everything is shadeless. also make sure you have not clicked ‘shadeless’ in the material buttons. if you are using the game engine you will have to paint the shadows into the texture, or use vertex paint to paint them onto the mesh. if you are not using the game engine, and you do not have shadeless pressed, put up the blend if you can, or a screenshot of your materials settings.

Hmmm. Definately not using the game engine, and Ive played with pretty much every button I can find, including shadeless ;).

Anyway here is a screenshot:

UV textured model on left, shaded material on right.

Here is the blend

I am using 2.33a and have tried the file on a couple of vastly different machines with little difference other than program speed.

Thankyou for your help!

I’m not sure what’s wrong, but try this,…unclick tex face, make sure the image is in one of the texture channels, and set the mapping for that channel to ‘UV’ instead of ‘orco’. that should work.

Are you talking about how it looks in the 3D View? Or how it looks in your final rendered image?

I was talking about how it looks in the 3D view. UV texture shading works fine in the rendered view however.

I think you have answered my question. I was assuming UV textures would exhibit shading in the 3d view since material textures did. I am guessing now that they dont.