noob render question

when I hit f12 to render the model is solid black on blue background. have searched the forum and could not find solution. thanks

You have any lights in your scene?

EDIT: Welcome to BlenderArtists.org!!

Yes, you most probably have no light. Just add some type of lighting (Add > Lamp > …) and move it around to fit your needs.

that was it. thanks a lot

The “blue background” that you see is actually Blender’s (adjustable, o’course…) way of indicating areas of the render where there is nothing there. Since every pixel of a visible image must have some color, it will be “blue.”

However… if you chose to render in a format that provides a so-called “Alpha” channel (which conveys “transparency” information…) you will observe that for all of those blue areas, Alpha = 0.0. They are, in other words, “perfectly transparent.” Likewise, the populated image areas (unless they happen to be translucent) will have Alpha = 1.0: “perfectly solid.”

This notion is crucial for compositing.

You can change that stuff in F8 (world settings) and F10 (scene or render or sumthin’ - just for the transparency on/off).