Normal Map baking is messed up

I have been making some models for a game recently, and have been trying to bake normal maps from a highpoly model to a low poly model. (Using tangent and selected to active)
However, i get the weird maps:

At first i thought it looked like some strange z-fighting was occurring, but there’s only one model i have selected and there’s no faces that are fighting.

I’m pretty experienced in blender (at least in my opinion) but this problem has been happening to me recently
I have searched around for a while now on this problem with no answers

Check you haven’t any double vertices. It looks like you have duplicated your mesh


I removed doubles from both models (high- and low-poly)
it found 4 doubles on the hight but that was it, problem remained

It may also matter that the high poly has subsurf as well as mirror modifiers on it.
Also highpoly and lowpoly are in seperate layers, but i select both layers when doing the bake

Collapse all mirrors and make sure that no polygons are overlapping in the UV layout. Your baked’ normals look suspiciously like you’re asking Blender to bake 2 sets of normals into the same UV space.

I applied the mirrors (I assume that’s what you mean by “collapse”)
I moved some vertices around in the UV editor to see if there were more faces under them, but it appears the UV maps aren’t overlapping.

Problem prevails… :frowning:
I wonder if when i select two objects (even though it is selected to active) if it is trying to render both objects’ normal maps (that doesnt really make much sense though…)

here’s the .blend file if it’s any help:
tallbarge.blend (192 KB)

hmm. in your file you didn’t apply mirrow modifer.
if this is not the solution - try to place both obj at the same layer.

Ya, I didn’t save the file after the mirror modifiers didn’t work… (But thanks for the help)
I tried the same layer, didn’t work either…
I’m going to load the model into blender 2.5 and see if that helps (im using 2.49b)

You said you’re baking with ‘Selected to Active’ enabled. If so, you must have more than one object selected. Your Lowpoly object must be the active object (selected the last)
[edit]Also, have you changed the Dist, and Bias values below your SelectedToActive button?

Tallbarge.blend works perfectly for me with no changes. I didn’t move any objects to the same layer or apply any modifiers. Just select high-poly, select low-poly, bake normals. Looks fine. No idea what the problem could be on your end.

Oh yeah, I did apply a new image to the low-poly object (select all faces, image>new in the UV editor) because obviously you didn’t include the blank image you were using.

Trying on a few different computers… i messed around with Dist and Bias, and some of the combinations seemed to at least fill in all the space which should have maps, yet there are still “jagged”

With your blend without any changes to settings I get this.