Normal map baking problem (2.2 MB)

Good day! Can you please tell me why, when baking the normal map for my symmetric object (the file is attached), the map on one side of the object is bright (the surface of the object shines when viewed), and on the other side the object is matte?

The normal map is clearly incorrect, but rebaking keeps making the same incorrect normal map. There’s something weird with that file. I can’t figure out what it is. But if I copy/paste your object into a new instance of Blender and bake the normal map there, it comes out right. (As right as it’s going to be, considering the high and the low.)

After copy/pasting and rebaking:

Hopefully that will work for you, and whatever weird settings are screwing up the bake aren’t saved into your preferences or your startup file.

1 Like

I have seen this behavior with the mirror modifier. I believe it’s kind of a rule not to use reflected geo/uv when normal maps are considered.

Film Exposure is set to 2. Not sure if it should be affecting normals bake, but it does.

You couldn’t have seen this behavior with the mirror modifier. And there is no such rule. When using mirror modifier for baking (which is not related to this case in any way), you need to make sure that overlapping mirrored UVs are out of baking area, that’s it. Easiest way to do that is to just offset them by 1, you can even leave them like that afterwards.


I tried fixing that, setting it to 0. Still baking weird. Checked all the rendering settings, not sure where it’s going wrong. 2.91.0.

Edit: Oh, I was fixing color management/exposure. I didn’t even realize there was a film/exposure. Yup, that fixes it. I’ll have to see what film/exposure does, I’ve never played with that before.

I’ve reported this just in case. Doesn’t feel like exposure settings should have an effect on non-color bakes.


Probably shouldn’t, no. (Although I wouldn’t mind if we could run compositing on bakes without having to jump through hoops…)

Thank you friends, I suffered with this for many days! Problem solved with your help!