Normal Map Baking Problem

I’m trying to figure out the best workflow for generating normal maps in Blender. But I’m having some trouble:

http://i48.tinypic.com/2hrlt1j.png

As you can see, I’m getting a weird seam in the smiley face’s mouth. But I’m getting ahead of myself. Let me go through the process I went through, and with any lucky someone can tell me what I’m doing wrong.

First I started out with a smooth shaded cube:

http://i49.tinypic.com/331zu6w.png

Here is my UV Layout:

http://i45.tinypic.com/iqyjbp.png

Then I added a multiresolution modifier and I added 7 subdived levels. I then sculpted out a simple smiley face.

http://i45.tinypic.com/2quhkex.png

In the multiresolution modifier I set my preview level to 3 and baked out this normal map:

http://i50.tinypic.com/2irkjec.png
http://i48.tinypic.com/34pz0qx.png

As you can see, I’m having problems where there is a break in the UVs. Can I not have a brek like this in the UVs? I’d be grateful if someone could shead some light on this…

Oh and if it helps, I’m running Blender v2.66. The 64 bit version on OS X 10.8.2

Try to apply the normal map with lighting to your preview level 3 mesh (since that’s what you baked it to).

I think you’ll find it looks fine.

Cheers,

Morten.

Morten,

The first screen shot I posed is the normal map applied to level 3 with lighting. It does not look fine…

Yeah I saw that shot but you clearly just set it up wrong.
I doubt you checked normal map in texture settings. If you think otherwise then make your blend available.

Cheers,

Morten.

This checkbox?

I’m new to blender and it’s very probable I have something setup wrong. That’s why I’m here. If you thought I had set it up wrong why didn’t you say so in your first reply. I’m not trying to start any arguments, I’m just sayin…

Anyway, I’ll be happy to post my blend as soon as I can find somewhere convient to upload it. It doesn’t look like these forums allow attachments.

Due to blenderhead/spammer distinction mechanisms used you have to have more than 10 posts to be allowed to use attachments here on forum. Meanwhile pasteall.org is pretty place to put stuff to test here.

All i can say, i did test your steps described here on linux 64 bit v.2.65 and i get nice result - there are no normal errors.

So, looks like your file is needed to see what’s wrong.

Ok here is an Update. Even though the normal maps aren’t displaying correctly in Blender, they display correctly in Unity3D. So the maps are baking correctly, even if they look funky in Blender. I loaded my scene into Blender on a friend’s computer and everything worked as expected. My friend was running Blender 2.65. I downgraded to blender 2.65 and things are working fine on my computer as well.

I don’t know why 2.66 wasn’t working for me. But I’m content with 2.65. I’m going to stick to that version for the time being.

Do you think perhaps you could make the blend file available? If there’s a bug in 2.66 it would be nice if it could be fixed
going forward you know :slight_smile:

Cheers,

Morten.

I just tried myself doing what you described in 2.66a and it worked for me.
Just thought I’d let you know.