Normal Map does nothing in Viewport and Render, but shows in the Preview Pane.-Cycles

Hi Guys,

Been watching a few tutorials on getting realistic textures with normal maps, spec maps and displacement maps. Unfortunately, every tutorial I watch is a different version of Blender and everyone seems to have their own way of doing things. Take a look at my results here with a simple hardwood floor. In the viewport, the image is flat as well as the rendered image, but the preview shows the reflections as they should be on the wood, am I missing something here?

/uploads/default/original/4X/d/1/b/d1b1ca4b84623d53433e1babc849abc9b5dd0072.PNGstc=1

/uploads/default/original/4X/0/0/6/006b7e680107e6e0fbef36e0eb25b45a1ebee906.PNGstc=1

Here is my node editor, the textures from top to bottom are the Specular, Diffuse, and Normal Map:

Attachments




Normal map textures need to be set to ‘Non Color Data’ instead of ‘Color’
I assume that you are using a tangent space normal map so try setting that in the Normal Map node
Also you are using generated texture coordinates for the colour texture but UVs for the normal map and the texture being used for the mix factor (nothing connected to vector input). I assume you want to use the same texture coordinates for all textures ? If so then make sure they are all mapped correctly, if you set to use UVs ensure that the object has UVs

Thank you, that is exactly what the problem was. It was my first time so it slipped my mind. Thanks again.