Normal map don't show at render

My normal map don’t show at render but work well in viewport.

care to share your file, or a screenshot or anything?

i am new user and can’t send blender file. Why you need screenshoot? I made uv mapping and normal map work well in viewport but don’t show in render only. What screenshot you need?

There are 10,000 things that could be wrong. I can start throwing out guesses, but I’m not a big fan of wasting time. Seeing what your shader setup looks like will make it much easier to help you.

I just wanna help you without wasting both of our time.


Try adjusting the position and/or intensity of your lights. If the light is at too direct an angle it will be hard to see the bump effect.

multiply this by 1000 and then do it again… and again… and again… and again… :wink:


I use only hdri for lighting. I told you it work in viewport so it’s not light problem.

The fresnel which controls the mix factor itself has no normal input… ?!? This is intentional ? It may show differenttly in viewport (eevee) and render (cycles? you didn’t mentioned)… (and that’s the reason to show screenshots of the setup…).


It work well without alpha.

We really do need to see your file. If you’re so “new” that you can’t post blender-files yet, contact the site owners and they can help you. They can do magic …

1 Like

As @sundialsvc4 mentioned, not much we can do without screenshots. I’ve upgraded your account level slightly so you can add pictures

1 Like

Hi there,

The Fresnel controls the mix, and it tends to be very blurry (use the fresnel factor to tighten it up maybe). Now, the normal should only show on the part where the fresnel masks it out. I dont see your normal map so I don’t know how visible it should be

I honestly don’t keep track of when a mask should be mixed A+B or B+A… Maybe try changing fresnel or use a layer weight node instead, try the two outputs there

Also, you may simply want to switch the mix plugs reversed.

Just quick thoughts. :grin:

Problem solved. Denoising blur my normal map so i turn off it and it work well now.

1 Like