Normal Map from sculpt

I have a low poly model, and I wish to give it a normal map.

I threw on a multires modifier, sculpted it a bit, and now I want to bake a normal map from the sculpt, using the model’s UVs.

So, I go to the render tab, I go to “bake”, I select “normals” and check “Bake from Multires”.

Blender output the normal map texture, and it’s in the shape of my UV’s and everything, but it doesn’t contain any information about the normals, it’s just a flat blue-ish colour.

What might I be doing wrong?


Is your viewport still set to the highest level ?
See http://code.blender.org/index.php/2011/06/baking-from-multires-data/

                      Is your viewport still set to the highest level ?

Yes it is.
Aha! Having read your posted link, I see why that is the issue.

I’m getting it to bake now which is super.
I am curious now … is my normal map working? When I render with the normal map applied, it looks as though something might be wrong.

Attached is the model first without and second with the normal mapping on his body.
(Both have normal mapping on the hair)
IMHO the first one looks better. I don’t know if it’s because there’s something wrong with the second one or not. I’m using the proper UV projection - I don’t know what else the problem could be.

Attachments



  1. Make sure you have UV selected as the mapping mode for the normal map.

  2. There appear to be some “pinched” verts/face in the normal bake surface, and thus also in your high-rez sculpt. This can happen when using some of the sculpting tools, and made worse by not enabling “Smooth” shading, and yet worse again by not using subsurf.

Cool character BTW!

Cool character BTW!
Thanks! I’m making him for a game project with my friend.

Here’s the lion’s walkcycle :slight_smile:

Thanks for your advice. It wasn’t the sculpt, but I found the problem.
I apparently need to tell my texture that it is a normal map - there’s a checkbox that somehow got toggled off. The hair texture had it on, which is why it looks ok.

I checked “normals” to map the texture to the normal values, but I guess you also need check “normal map” (further down the panel) to tell Blender that it’s a normal map. When you do, you get the option to choose which normal space to use (multires bake uses Tangent space).

Incidentally, I don’t understand what the other normal spaces are supposed to represent or why you would use them. Tangent space is the only space that makes sense to me. Why would you use the object’s coordinates as a reference … or for that matter, the world space?

I’d be surprised that smooth vs solid shading would make any difference for the bake because it just tells Blender to interpolate shading between the edges of an individual face and the normals themselves aren’t changed … or were you referring to the shading setting on the final low-poly model? It might affect the outcome there.

The other normal options were those that preceded tangent space, and work properly only for static objects. As I understand it, tangent space normal mapping was devised specifically to be used on animated models for games.

The pinching I mentioned can be seen in the groin area of the model, in the image that has the normal map applied (but not tagged as tangent). That looks much like the pinching that happens when using certain sculpt tools – over-using them, actually. With only two pics to evaluate (and assuming all the settings were correct), it seemed a possible source of the problem. You should try baking an object set to Flat onto one set Smooth & see if the shading affects the bake – I think it will, since the bake deals with full surface normals, including the interpolated values afaik. It’d be interesting to see the results.

Oh, static objects … ok, I can see how object or world space could function in those cases, although I’m not sure I understand what (if any) advantages they would have over tangent space. Is it faster to bake those?

I was going to experiment the smooth vs solid with a test case … but now I have another problem.

Here’s what I did. I create a cube, add a lvl 5 multi-res, sculpt it, and turn preview subsurfing to 0. I marked seams, and unwrapped the cube.

But now, I go to the render tab, check “bake from multires”, pick “Normals”, and hit bake, but I get the error “No object found to bake from.”
My cube is selected in object mode and I still get the error. Am I missing something else?

EDIT: I think I’ll start a new thread. This one started on a different topic.