Normal map problem after bake

i have baked a normal from my high poly object. But it works terrible as a normal map on my lowpoly. I did all good. It doesnt work. Is anyone know the problem please ?

  • i try both shade smooth and shade flat view
  • mesh, recalculate outside
  • i did applied Ctrl A rotation and others
  • U , i tried smart Unwrap and unwrap both

This is my lowpoly with normal map in cycles render

1 Like

This map looks very wrong :thinking: How did you bake it?

with bake option in the cycles render. i ve saved a png file first. After i bake the map to png.
I cant understand what im doing wrong.
files are here ;

colomn hp.blend (720.8 KB)

colomn decimated.blend (726.8 KB)

Ooookay… I’m not sure what I’m looking at.
So what you’re usually supposed to do here is:

  1. Start with BOTH high and low poly in the same blend file.
  2. Select high and then low (last selected will be “active”).
  3. Check Bake > Selected to Active. Play with Extrusion parameter to avoid artifacts (generally a small value).
  4. Chose Bake Type, select your target image in Materials and Bake.

Actually this would be more informative:

i did again. i applied shrinkwrap. better result but still it is not usuable. I can see lowpoly object corners and faces on my object (lowpoly+normal map)…

Those might be Cycles not doing a very good job with low poly objects. Does it look the same in Eevee/Material Preview?

yeah , it looks bad in the evee as well. I cant understand what is the wrong :frowning:

  • Set your lowpoly to Shade Smooth
  • On it, in object data properties, Normals enable AutoSmooth and set the angle to 180 degrees, and in Geometry Data click ‘Clear Custom Split Normals Data’ if there is such a button (it won’t necessarily be there)
  • In edit mode, mark all UV seams as sharp (select one edge that is a seam, Select -> Similar -> Seam; Edge -> Mark Sharp)
  • In object mode, make sure that your high poly and your low poly are located in the same place and are overlapping each other
  • In bake settings, set Cage Extrusion and Ray Distance to some low value (you’ll likely have to make a few bakes until you get those right)
  • Create a new image to bake to; make sure you set it to Non-Color Data in the texture node
  • Bake Selected To Active
2 Likes

thank you for answer.
I cant do third step. I cant find the “mark sharp”.

Be in Edge selection mode, Select Similar menu is context-sensitive. But that is for selecting seams. Mark Sharp is in the Edge menu, not Select.

Though, looking at your screenshot again I don’t see any seams. You might need to do one other thing before everything else: in edit mode select all, then in the UV editor, select all and there do a UV -> Seams From Islands.

1 Like

hello
i did all except select similar seem egde… I have looked Edge menu too… i didnt see context sensetive… I cant do those steps. I cant understand where is this.
my normal map has edges from lowpoly object. Is this ok for normal maps ?

01


03

No, it’s not normal. Let’s try this again:

The goal is to mark the hard edges around your shape as sharp.

  • In 3D view, select everything
  • In UV editor, select everything, and use the menu UV -> Seams From Islands
  • In 3D view, switch to Edge selection mode and deselect everything
  • Select one edge that is marked as seam in 3D view
  • Use the Select Similar -> Seam (it’s right there on your screenshot)
  • Use the Edge menu -> Mark Sharp
2 Likes

thank you so much. Pretty complicated but those steps are fixed the problem. I can bake a good normal map now for the object. Thank you :smiley:

i hate normal maps baking for this very reason, you have to tweak a lot of the uvs due the hard edges to get that shit working…

1 Like

The author of that video gives mostly good advice. Except at the end there it’s kind of convoluted, about sculpting and shading. It’s all much simpler: just don’t sculpt on your low-poly base, sculpt on a duplicate.

1 Like