Normal Map problems

Hello,

I’m having a problem with my normal map where the UV lines are overlaying on top of the map causing thin black-lined to appear on my low poly mesh. I’ve attached a link to a .rar file containing my .blend and normals map. Thanks.

https://drive.google.com/open?id=0B7_KwlWUftqjUmVnamx6UWw2VzQ

Are you trying to keep it top secret or do we have to beg for access ?


Oh sorry, check if it works with this link:

https://drive.google.com/file/d/0B7_KwlWUftqjUmVnamx6UWw2VzQ/view?usp=sharing

Oh sorry about that, check if it works with this link:

https://drive.google.com/file/d/0B7_KwlWUftqjUmVnamx6UWw2VzQ/view?usp=sharing

Some obvious mistakes.
Your objects hadn’t been set to smooth shading, hence the faceted normal map.


Set to smooth shading


When you uv unwrapped did you enable the option in the unwrap settings to take in effect the subsurf (use instead of the multires for the low res object). The bake does not fit to the UVs correctly


On the high res object it looks like you have sculpted some undercuts, this will cause problems when baking the normal map (dark lines)

When I did the unwrap I used blenders smart uv unwrap, I’m not sure how to properly unwrap manually and as for baking I used x normal and the result you got with smooth shading I was able to get a result like that when I set the low res object in xnormal to use average normals, but it caused problems for my mesh when I ultimately exported it to unreal engine 4

When I did the unwrap I used blenders smart uv unwrap, I’m not sure how to properly unwrap manually and as for baking I used x normal and the result you got with smooth shading I was able to get a result like that when I set the low res object in xnormal to use average normals, but it caused problems for my mesh when I ultimately exported it to unreal engine 4