Normal map working in Eevee but not in Cycles?

The following screenshot should show all the relevant information. I have a Sculpted chairmodel with details that I want to bake on to a low res model. But the resulting normal map looks like the one in my screenshot the sculpted details just won’t show up in the normal map.

Does anyone know what I did wrong? Thanks for reading.

I tried recalculating normals and got this now:

Enable the Cage option, increase Cage Extrusion a little bit, and decrease Max Ray Distance so it’s about twice the Cage Extrusion (or a bit more). From the looks of it (those dirty yellow spots), what happens now is rays from the low-poly are missing the outside surface of the high-poly, travel for the defined 0.5m Ray Distance and hit the inner back-facing getometry of the high-poly along the way.

1 Like

Thanks a lot it looks correct now! But there is one issue left. I get weird black artefacts on my model when I go into rendering mode (it looks fine in Material Preview). Any Ideas what could be causing this?

Rendered Mode:

Material Preview Mode:
normal_map_problem3b

Not sure what that is exactly. I could take a closer look if you’d like to share the file.

Thank you. I will upload the file to google drive real quick if that is okay. I tried uploading here but it is too big.

Any hosting is fine so long as it’s not an ad-spamming nightmare :slight_smile: Aside from google, pasteall.org/blend/ works too (though AFAIK they also have a size limit).

Thanks. Heres the link:
https://drive.google.com/file/d/1p9uP6E4Dnx0M_sFU8D0fVmgjd-qhX0mr/view?usp=sharing

Ah sorry. It did not save the UV Map I noticed because I exported the models and reimported them in a new blend file to see if that would work. Here is the original file.

https://drive.google.com/file/d/1s1xei71D--qE_qhliAGuMhBS9PlGotFZ/view?usp=sharing

Edit: The high res chair is in the “non render” collection in this file

I’m not getting any rendering artifacts in either file. In the latter file, the high-poly chair object has its Ray Visibility turned off for everything in the object properties, that’s why it wasn’t baking properly.

1 Like

Wow… how could I miss this :sweat_smile: … Thank you! Everything works perfectly now.

Actually after some more experimenting I am unfortunately still having issues when rendering in cycles. (Eevee works fine). Maybe this is some sort of bug? I will mark this thread as unsolved again, maybe someon knows the reason for this problem.

Evee:
(It

Cycles:

Very strange. This is with the “normal” node connected and without.


You still have that image texture node as sRGB, need to change it to Non-Color Data.

It seems to be greyed out and I cant change it to non color data :confused:

Yep, you’ll need to create a new image for that to work.

Ok I tried changing it to non color-data but I am still getting the same artifacts (like the last image I posted) in cycles but not in evee.

Ah wait it automatically switched back to sRGB once I loaded the image and connected it? Very strange. Now it is grey again and I can’t change it back to non color data.

I’m starting to think this might be a bug? I just created a new Image and set it to non color-data from the beginning and baked the normal map again onto this new image. Its now set to non-color data, but I am still getting the artifacts. The Normal map looks correct, and the uvmap is correct in the UVEditor. But when Rendering it looks like the UV map is wrong?

Here are two screenshots where I canged nothing but the render engine, with very different results:

Eevee

Cycles

I’m still not seeing these problems here. Could you perhaps get the file to show the problem and upload it again?

1 Like