Normal-Mapped Textures in Game Engine

Hey all, kind of new here, but I could use some help…
While messing with rendering styles, I discovered a cel shading method I greatly prefer to the usual Toon Shader. I’d like to make use of this style for games, but my attempts to replicate it in the game engine have not gone well.
The style works by making the material shadeless, then applying a semi-transparent shading texture to the normals. The style even works within the editor window, with the normals adjusting based on your viewpoint. Example image 1.


However, when playing the game, the textures mix abnormally, and the shader isn’t affected by the normals at all. The shader seems to take priority, patches of the model being totally transparent, and each individual poly sporting its own copy of the shader texture. Example image 2.


Does anyone know why this may be happening? And more importantly, how I might be able to fix it?
I’m running 2.74, btw

Attachments

TexTestPortable.blend (1.09 MB)

Are you not going to supply a demo blend so we know what you have done

Oh, sorry. Like I said, new here. I’ve updated the first post with the .blend file.

you forgot to pack the texture images to the file

Evidently, my newbdom knows no bounds. Hopefully this works.

In the Render / Shading panel (when using Blender Game engine) you’ll need to be using GLSL not Multitexture for that type of texture to show correctly

And how do I go about that? I checked the Render/Shading panel, and I didn’t see any such option. A tutorial for an older version said the same thing,

Ensure you are using the Blender Game engine


Well, good to know I’m a total and complete idiot. Thanks a bunch. Issue Solved.

Um… Also remove transparency from each of materials. A bug of importing that sometimes occures is the transparency is set to true, which makes it have some glitches on it in runtime(visible ear through face, a gun which you can see through trousers or a wheel that is in other side of car opposite you), so unchecking it will fix that…

Thanks~ I actually noticed that problem with Waluigi, but when I tried some of the other stock models I have, it didn’t occur with them…

Ahh, that tasty bit of info helps me also. Didn’t understand why I could see my ghouls arm through his chest. :slight_smile:
Thanks Adrian.

:slight_smile: