Normal Mapping wierdness

Hello all,
I am new to the forum,so if this has been covered elsewhere, please be patient. I was following the directions for Normal map baking as described in a popular video tutorial.

It worked as described on a plane, so I tried it on a recent model. And this is what happened after pressing the bake button (with NORMAL selected)

It is probably something really rudimentary that I am missing. I had punched up the multires to about 4, and sculpted away, I was just trying to get some bumps and dimesions:

then,baked normals, reduced mesh resoultion down to original, and when it mapped, i got what was in the first picture.

as I said this is my first time out with this type of thing. I am doing this on my laptop–it has a ATI Raedon Xpress 200M series in it (which I had to disable hardware acceleration on in order for Blender to run properly), 1 gig RAM, Intel core Duo, XP media center. I have heard of the Catalyst driver problem, and thought maybe…however, instinct tells me it is user error more than anything.

If anyone can offer insight into this phenomenon, I would be most appreciative!

One final thing…As I am new to this, I have been poking around. I suppose what I am trying to do is what would be called Tangent Space Normal map baking–as evidenced in the recent Gallery post of the trooper that a lot of folks said looked like a Doom character. It appears that there is more than one way to skin a cat, so I started with what was the most straightforward approach (the vid tutorial). I realize that this cant be achieved in this step alone, however, I didn’t expect the results I got!

I look forward to and welcome all replies!

I’m not really familiar with Baking, but Tangent Space Normal Map Baking is a new feature that it not in 2.45. Perhaps someone else can help you with your current problem though.

See this page.