Normal Maps problems with MindTex


[WARNING: for some obscure reasons I couldn’t upload here my zip file. Here is the link to it from my OneDrive:]

I’ve bought a sftware called MindTex to create Normal, displacement, specular, ambient occlusion and self-illumination maps. I thought this was equivalent to CrazyBump (which costs a LOT more), but I found out that I cannot import the maps in BLender.

I’ve tried many times:
This is the result with a normal map generated with CrazyBump (I’ve got the demo version)

Which I think is good.
The screenshot of my nodes in Blender (Cycles):

(Normal maps are attached, I cannot attach diffuse cause licensing limits. You can find the texture from under
FloorStreets0072_1_S name)

Then I’ve repeated the same with MindTex and this is the result (without changing any setting to the normal map):

Which is a really bad looking result.
I’ve not changed anything except for the normal map image in my nodes editor…
So I’ve tried to decrease the strenght of the effect to 0.5, but this is the result:

And I’ve also tried to play with the settings of the normal map in MindTex, but the result is always the same:

But on MindTex the result is looking quite good on a plane with only normals enabled (original normal map created with MIndTex):

Attached to this post you’ll find a folder with all the screenshots from there, the normalmap created with CrazyBump and three normal maps created with MindText: one is the original, the “new” is the second screenshot and the “newinv” is the “new” normalmap inverted with the invert shape button in MindTex.

You won’t find the diffuse texure as I cannot share it according to licensing issues. You can download it from name: FloorStreets0072_1_S.

Can you please help me to achieve the same result as CrazyBump with MindTex?
I’ve watched an Andrew Price’s video which told me that Blender uses Down-Right normals directions, but I don’t know how is MindTex set on this behaviour because I cannot find it in Settings…

My question is how can I remove those black lines in the MindTex normalmap?

Thanks a lot for your time, patience and help!!:slight_smile:


See the annotated screenshot of you node setup:

Thanks a lot! It worked for me if I use the diffuse map generated by MindTex and not the original texture (it seems that the normal map is shifted horizontally).

To do the same in Blender Render I have just to set up two textures: the first has to be the diffuse map and the second the normal map. The first has to influence only the colour component while the second only the normal. Is this right?

Thanks a lot again!