Normal Maps with Blender internal

I am sure i am doing something wrong but i dont know what. I made a model rendered with yafray all the bumps from nor maps are visible. But if i render it with blender internal i dont see the “bumps”. I added a texture ,uv mapped it and in texture propertis turned on “Nor” so i really dont know whats the problem…any help is welcome

did you turn on Normal map in the texture editor (where you uploaded the image)?

crank up the Nor slider on that Map To panel. by default it is very small and the texture has little effect.

Thanks for the replays. I tried turning on Normal map where i uploaded the image but it didnt make any difference and also i dont think the settings are cousing the problem becouse with yafray the bumps are visible. The nor is set to 2.5 so it should be visible…i tried opening a new blender project and apply the same texture to the default cude and just setting it to nor and it worked…so i dont know why i cant make it visible…