Normal problems? with rigged meshes

Whilst using constraints to get my character to look in the right direction I noticed the normal maps were distorting as it turned ( but only in the game engine, the view-port is fine), here’s a screenshot of where it’s most noticeable.

(A is viewport, B is in game)

For a while I though it must just be the model so I tried to fix it by reverting to default values/ recalculating normals/redoing the rig, to no avail however.
I then decided to create simple .blend where I isolated what I thought may be the problem, and lo and behold, the problem appeared once more!

(left is in game, right is viewport)

When rotating objects on their own this doesn’t happen, however If they are rigged and you rotate the bone they’re rigged to, what I guess is the normals, distort like this.

However it only happens when there is a normal map applied (a proper normal map, not just applying bump to any texture) the next screenshot is the same material with the normal map texture simply unticked…

(left is in game, right is viewport)

I’ve tried the .blend in 2.62 and 2.59 and it seems to be a persistent problem but I’ve been unable to find anything about it? (if I’ve missed something, I apologise). Also to be sure it wasn’t just my pc, I’ve tried it on another computer and the problem was present there as well.

(the only similarity between the two computers is they both run windows 7 64bit)

I’m pretty stumped! and as I said I can’t find anything relating to this, If anyone has any ideas or can point me in the right direction it would be appreciated.

I’ve also got a link here to the test .blend, in case you want to test for yourself.

Sorry for raising this thread from the depths, however after looking at the 2.64 test release I noticed that the one way round this problem, which was to place a modifier in the stack after the armature, doesn’t seem to be possible in the new build. so we’re essentially stuck with messed up normals on rigged meshes! (this way of getting round it tended to butcher the framerate anyway.)

Is this a problem unique to computers I have used, or have other people experienced it as well? I only ask because I’ve yet to find any information on this, apologies if this is already a known issue.

report in the bug tracker if you think this is a bug :wink: