Normals are wrong when creating a mesh

If I create a cube mesh using Add->Mesh->Cube, the normals of each vertex on the cube are pointing out diagonally. If I created a box in 3DS Max, each vertex would have 3 normals, each pointing perpendicular to each of the 3 faces it’s attached to. Is there some way to get the Blender cube to do the same? Otherwise, when I add a diffuse shader, I get these funky gradients because the normal isn’t facing straight out of the face.

Blender doesn’t display multiple vertex normals per vertex, only the combined result. I don’t think that is the reason you’re having trouble with your shaders though. Are you using smooth or flat shading? Cycles or Blender Internal?

I know I want to use flat shading. But I’m not sure how to turn that on. I don’t know what “Cycles or Blender Internal” means.

Select the object and press Flat Shading button in the toolshelf (shortcut T)

I don’t know what “Cycles or Blender Internal” means.
These are two renderers that come with blender

I’m using 2.49, but I found the equivalent options (according to but choosing set solid doesn’t appear to do anything. I tried creating a new canvas, selected the starting box, selected set solid, imported the mesh into Unity, dropped a normal shader on it and I’m still getting a gradient on each face instead of a solid color.