Normals not in center of mesh, how to edit? Help! :)

Hello all,

I have a problem that i really could need som help with, some normals are not centered in certain faces in my mesh: please see attached image; does anyone know how i could fix this?

Cheers

That’s an n-gon. Normals are displayed at face median. Which, in this case, is closer to the right and bottom because there’s an extra vertex there, hiding behind that platform. If you don’t want this, the solution is to not have n-gons.

1 Like

Hi Stanislav!

Than you for that clarification, I now understand that this vertex is what’s “causing” it not to be centered as the other ones, does this mean i have to make seperate meshes for it to be centered?


Cheers!

No, it means you shouldn’t have an n-gon there :slight_smile: For example, you may use the Loop Cut tool and Knife tool to cut an additional edge loop like this:

This way you’ll have all quads there. It looks like you may want to do that in all other places too.

1 Like

Stanislav, thank you for taking your time with me :slight_smile:
The thing is, i had a loopcut there before, but i want them all to be of this certain size since im adding another object in sverchok to the facade, that attaches to the normal positions, and therefore i need them to be the same sizes as in the image, therefore i don’t want another extra normal with another loopcut? Are there any other options then for me ?



Cheers!!

I think it’s a matter of choice. If topology is important to you, the loopcut solution is the best, afaik.
If it isn’t important and you just want to have all quads, you may select the face with the extra vertex, press P and separate it from the rest of the mesh.
Edit the separated face and remove the extra vertex (dissolve it). Rejoin the face to the rest of the mesh.

Add: it seems the face to the right of the rectange has the same problem too, as any other square face near to one of the rectangles…

2 Likes