Normals not pointing in the correct direction-

Hi, I am using a build of 2.37 and the normals in my model don’t appear to be pointing in the correct direction. I appear to have the same problem in 2.36.

It is an issue as I want to scale extruded face loops on parts of the model along the normal. eg. on the bumper.

Does anyone know the obvious that I must be missing?


:o That’s… very interesting…

Have you tried Recalculating normals (Ctrl+N)?

try appending the mesh into a fresh file. maybe with an older version. i don’t know what the deal is with that mesh, though i vaguely recall seeing something similar. if you can’t fix it, i’d write a bug report.


I had tried ctrl-N with no joy.

I did as you suggested Modron with no joy.

Here is a pic from 2.36.

I modelled this using a cube and then used edge loops with the occasional deleting and recreating of faces manually. It is very odd.

I tried some tests with a sphere and it seemed to work as I would expect. It is just my mesh that seems to have some problems.

Hrrm I tried a few more things.

I used p-key to seperate and any new polygons have the same problem.

flipping normal has inverse problem.

Any mesh created whilst in edit mode ie cube has the same wierd problem.

If i create anything whilst in the ‘pink’ mode (object) mode has correct normals.

Select your mesh in object mode and Ctrl+A.

Ah cool, thanks that worked. Now to read up on what that did :stuck_out_tongue:


I’ll save you the trouble :wink: