Normals or Material Inconsistency

I have ripped a Mario model from Super Mario 64. I discovered the vertices were never touching, and so I removed doubles, and this fixed the smooth shading option most of the way. Now I am having troubles with consistently lighting the normals that I have recalculated time and time again.

Here is a screenshot. I just want the lighting to “blend” or “smooth” better across the model exactly how the head is. I simply rendered the workshape, moved the camera out of the way in Orthographic view, then took the screenshot.


If you need it, I can send the .blend file, but I would rather do that in private, as this model took plenty of time to get in its current state. Trust me, if it was easier to fix and get, I wouldn’t even care.

1 Like

voce poderia me enviar o arquivo por favor , eu estou fazendo um jogo na tematica de mario 64 , e quando ele sair eu posso ate compartilhar seu trabalho. o seu nome estara nos creditos. meu email e : [email protected]

It’s a ripped model? There’s a good chance that it has custom normals (which often aren’t imported properly, who knows why, and which Blender typically screws up whenever it merges verts, again, who knows why.)

Look on properties/object data/geometry. If there’s a button saying “Clear custom normals”, click it. After that, if there are still issues, enabled Autosmooth in properties/object data/normals, with an angle of 180 degrees.

After that, if there are still problems, enter edit mode on your mesh and use “select non manifold” operation, and fix anything that gets selected.

Just want to add, I know that when you’re starting out it takes a ton of work to get anything done. But really, if you’re working on a rip, if you’re a beginner (and you can tell you are, because you’re asking for help), then nobody wants to “steal” your model. (And let’s be fair here, if it’s a rip, you’ve already “stolen” it anyways.)