Normals problem

So I ran into a bit of a problem with my most recent model. If you look at the pic you can see this nasty black outline on part of my mesh which looks like a normals problem to me. When I recalculate normals it doesn’t fix it though. I’ve removed all of the doubles so I know that isn’t the problem. And the outline doesn’t show up in edit or object mode, only when I render the mesh. Does anyone have any thoughts?

Also if I turn off set smooth the problem goes away.

Any help would be much appreciated =)

Attachments


Turn on your normals so you can view them. In 2.49 in edit mode, it’s in the mesh tools more panel. Some of them maybe pointing the wrong way even after recalculating normals. I ran into this once, the only way I found to correct it was to manually go in and select each face with the normal pointing the wrong way and w-key -> flip normals.

If anyone knows of a quicker way to fix this, I’d love to hear it…

Randy

Make sure you don’t have any faces inside your mesh which shouldn’t be there, this will mess up your normals recalculation.

I’m guessing you are using subsurf and you have creased those sharp corners. This causes problems when you try to use smooth because the angle between the faces is to sharp. To fix this, use autosmooth/edge split or lower the crease value of those corners