Normals showing up on both sides of new mesh.

For some reason, whenever I add a primitive mesh (plane, cube, sphere, etc.) the normals show up on both sides. I’m guessing I accidentally pressed some key combination and changed some setting. When I first started this model, it wouldn’t have normals showing up on both sides, now it does, even when I add a brand new primitive mesh. I’m building this model for use with the Unity game engine, so this creates problems as it only recognizes one normal. Any ideas on how to fix this? I found the “double-sided” option in Blender - the problem persists whether it’s checked or unchecked.

Can you chop down your blend file to a minimal object with the problem, maybe one or two lights and a camera, and post it or a link to it? This sounds like an interesting problem to diagnose.

try to upload file so we can check it !
and show us some pics also

thanks

Sorry for the late reply - not sure what I did, but I fixed the problem by removing all my materials (the model was untextured).