Not bad 4 my 1st project, so far, but...


(chuck_starchaser) #1

(The first Wing Commander Hellcat V pic is from the internet; below it is my model. Actually, I started working from an existing mesh, but a very simple one; you wouldn’t recognize it by now.)

http://www.deeplayer.com/dan_w/hellcat/compare3.jpg

… but I’m a total newbie, and I don’t understand what’s going on…
For example, those little squares on the side of the body are actually cubes going across… I put two internal cuts near the ends and scaled up the cross sections of the cubes on the inside to get 45 degree sides. But they seem to be separate meshes, separate objects. I was working in split view, and at one point those separate objects disappeared from my right view. Poof, gone. Couldn’t see them on the surface, couldn’t see them in edit mode, couldn’t see them even in transparent mode; but they were still there on the left view, so I got rid of the right view before it might corrupt my file, if it was due to a bug…
Anyhow, I want to merge these embedded shapes with the main body; but I don’t know how. For boolean operations one is supposed to select the meshes to merge; but I don’t know how to “select meshes”. Could someone give me a keystroke by keystroke instruction, or point me to the right tutorial? TIA.


(macouno) #2

Select an object (outside of edit mode (tab key)) with the right mouse button. Hold shift and select multiple.

If you have multiple selected click CTRL-J to join them (or find the join function in your space-bar menu.


(chuck_starchaser) #3

Allright! That worked. What I had in mind, though, was that where the meshes cross, vertexes would be created, and the stuff inside could be deleted. I believe that’s a boolean op? Boolean ops is what I was looking for in the tutorials.


(macouno) #4

If you have a recent version of blender (2.4) look for the modifiers… add a boolean modifier whilst the 2 objects are still sepparate.


(chuck_starchaser) #5

The good news is, I figured out how to do boolean ops…

(For fellow newbies having the same problem: This is done in Object mode, not in Edit mode. In object mode, you right-click on the main mesh and it becomes outlined in purple; then you shift-right-click on another mesh to add it to the selection. The problem is, you see nothing when you do that, unless you’re in transparent mode (hit Z), in which case the second mesh goes to another shade of purple. If you just want to join them, hit ctrl-J; but if you want to cut them and weld them together, hit W and select Union. An unholy number of new vertexes is created. The whole original mesh is still selected; you can now de-select (shift-right-click) all the facets you want to keep, then press X and delete faces and lines, press X again and delete vertexes.)

… The bad news is it didn’t do a good job at all: My neat squares were deformed, and subdivided into gazillions of triangles. Bad tesselation algorithm, probably. Anyhow, I forgot to save before doing this experiment; couldn’t undo it after trying to merge vertexes for like an hour, and had to reload the previous save, lost about 4 hours of work. Is there a way of doing a boolean op by hand? I mean, these square were protruding through flat planes; if I could just have that plane split the edges of the other mesh, I could put in lines and triangles as needed by hand…

EDIT:
We posted at the same time. Okay, boolean modifier; I’ll look for it. Yes, I have 2.40. Thanks.


(chuck_starchaser) #6

So, I selected the meshes, added the boolean union modifier, then W->Union and the program crashed. Couldn’t read address 0 for some reason :slight_smile:


(chuck_starchaser) #7

I’m doing my booleans by hand; --cutting and soldering. Tons of work, but I get what I want.
Another question: Any way to move or add a mesh from another blender file? I thought ‘Merge’ would do it, but it goes into the file like if it was a folder and asks me what I want to merge, the camera, the light, some mysterious cubes, the object or the mesh. I tried the last two and it tells me that the file is not a library…


(macouno) #8

Ah well… you’re trying to do a boolean over a boolean. The W key is a different piece of code to the modifier boolean.

In the boolean modifier there should be an “apply” button… try that.

Adding an object from another .blend file can be done through file/append.


(chuck_starchaser) #9

Holly mackarell! It works! Thankyou, thankyou; this was going to take me a week to do by hand… :smiley:


(chuck_starchaser) #10

Oh man!, this is so hard to understand… I never found an “apply” button. Simply, the moment I geve the main mesh and my other object the boolean union attribute the main mesh became tesselated and only the end caps were visible. BUT, the end caps sticking out looked like they do in Edit mode whenever I was in Object mode, and viceversa. Then I selected those end caps and joined them to the main mesh, and now it looked okay, but later I realized that the tesselation was gone, and the object was solid again. So I separated the object from the mesh with P, and gave it the union attribute again, and it worked again, but the display problem came back…

Also, when I created the object, I created 2 other duplicates, and it seems that the duplicates automatically became boolean union attribute when I set the attribute for the first, because when I tried to move them into the mesh there was all kinds of tesselation activity in real-time; and then the program crashed…


(Fligh) #11

Yep. Holy mackarell.

%<


(macouno) #12

Heh… no idea what you’re doing now, but the append function isn’t a button. It’s in the top menu File/Append, or shift-F1 apparently.


(chuck_starchaser) #13

Yeah, when I said “File -> Merge” I meant “File Append”. But no-one mentioned an “Append button”, only of an “Apply button” in regards to Boolean Attributes. By the way, I never got File -> Append to work for me, but I just re-created the geometry I wanted to merge; wasn’t much anyways. File -> Append always gives me an error: either “Bad filename specified” or “Object is not a library”.