Not capable of removing faces / edges

Hello everyone!
I am finishing a project in Bender, but I just realised that my scene is full of vertex and faces, probably most of them totally useless. The thing is I am trying to remove them but the file is that big that I can´t even select and remove. the system crashes and the computer gets blocked. I wonder if someone can help me to remove all those duplicated or useless vertex/faces by sending the file via email.

I am very stressed with this project I have to send it as soon as possible and with the COVID19 everything is a mess, first I had to set everything to telework now this…

I have to render it but I need help.

¿Can someone help me?

thanks a lot

What version of Blender do you use? What are your system specs? How big is the scene in polygon count?

1 Like

First. Make a copy of that file and open that.
If it are multiple objects try to edit them one by one

  • Edit Mode
  • Ctrl + A
  • In the menu go to: Mesh->Cleanup->Delete Loose

If something worked. Save it. Then continue fixing it

1 Like

I use the version 2.8 of Blender.

My Computer specs:
Intel core I7 4790 CPU @3.60 ghz
16 gb RAM
NVIDIA Gforce GTX 750

The file is 1.130.472 KB right now.

I am not sure If I can even count the polygons casue once I open and change from Layout to Modeling the computer crashes. (and it is in object mode).

I think I can’t even change a thing without a better computer.

:frowning:

UPDATE:
15.279.497 edges
15.004.668 faces
29.695.987 Tris
679/679 objects
5.78 mem

The version is 2.81.16
I deleted loose meshes and also used Decimate modifier on a car that I’ve got in the scene.
I believe the problem must be the light/world as well but I really cannot figure it out.

Would someone be able to open the file in other computer to see what’s wrong?

There is a trick that might work. Not sure it will but you could try it.
In Edit->Preferences->System. Disable Global Undo and Undo Steps to 0.

1 Like

Can you show a screenshot of what the file looks like?

1 Like

So I’ve been looking in your Blend file and it’s quite big. Up to 11gb of ram just to have it open.

Before doing any change you’d need to turn off the undo in preferences. ( Edit->Preferences->System . Disable Global Undo and Undo Steps to 0.)

Max subdivs for any object should be 2. One easy way to change it globally is to enable Simplify in Render tab. Change Max Subdivision to 2 in Render and for Viewport change it to 0.

Select all ZZ Plant Leaf object in the Outliner. Go to edit mode, the ram jumps to 14 GB but you have 16 GB so it should work. Once in edit mode, select all faces by pressing ‘a’. Right mouse button click and select Un-Subdivide. Wait for a minute for blender to calculate this. Every step of this will take some time. You can do this for any dense object. It’s less destructive than Decimate.

If you have many of the same copies, use ALT+D to link duplicate so the file size is not so big.

1 Like

I think this will work. I just did every step and it looks quite easier to move.
at the Un-subdivide step the number is 2. is that all right?
When I copy an object I press control + c and control + v. so what you say is that I should copy with ALT+D?

I am going to render it now. fingers crossed!!!
thanks a lot

1 Like

this step helped a lot as well :wink: thanks

2 Likes

Don’t forget when you are done with the project to return the Undo settings in the preferences.

Yes, it creates a link to the object and not a copy. So it takes barely any space as it references to the object.

1 Like

I am teleworking with Team Viewer and I still can’t render the scene. As soon as I press F12 the system crashes and I lose the connection with the PC. when it comes back (after 20 minutes or more) blender is clossed. :frowning:

That’s not enough info to really help you. It might be, that team viewer looses the connection because the cpu load is way to high to manage the team viewer process in parallel to blenders rendering.

If your remote pc is running windows you can eg try to reduce blenders scheduling priority in the taskmanager under the details tab and hope that the teamviewer stays connected. You might also carefully increase the prio of teamviewers process.

Just a thought. Hard to say what your problem here is.

1 Like

You need to turn off subdivision. In simplify set both to 0. The subdivision takes over 20GB of RAM and crashes Blender. I’ll test with ALT+D for the plants. Maybe it will work better. I’ll get back to you.

To fix the memory issue you need to ALT+D the leaves and bushes. They take several GB of memory.

Or you could link it by Ctrl+L

That is something I just learned. Do this instead!

Also remove subdivsion modifiers where it is not needed.