not displaying video in render

I am currently trying to make a cube sit on the ground in real life footage I filmed, but I am running into a brick wall. When ever I enable the settings for the sky to be alpha and my 3d object to sit on top of the scene, blender is not rendering the video. This method i am using usually works, the only reason this is not working is because it may have to do with this .blend being imported from 2.49 to 2.69.

Because I cant seem to get blenders camera tracker to work the way I want it to. I decided to try an external tracker. I tried voodoo camera tracker and that didn’t work. Then I found a program called Pftrack that exports tracking data into .py scripts. Unfortunately pftrack can only export the .py scripts into blender v2.49, if you were to try and export the script in blender v2.6x series then you would get an error. so I opened blender v2.49, executed the script, saved the .blend and opened it in blender v2.69, And now I’m having this problem. The executed camera data works but its just the rendering that’s not.
On the left of the two images I posted you should see what I want the render to look like and what it actually looks like on the right.

Is there anyway to fix this?
If not. Does anyone know of any external 3D tracking software that can export its data to blender 2.6x series?


Attachments


You are not showing all the important settings in your screenshots.

In the Image Editor window set to Redner Result, on the header have you set it to show the Composite result or only just the Render Layer ?

Well, I don’t use compositing. So I assume its just the render layer. I have never had to composite or combine render layers to do this. So I’m not sure why it makes a difference now.

Composite is the sum of all the parts = Render Layers + changes made in the Sequencer = The final render result

The render layer is just the render from the scene. This will have no background image because you haven’t added it through the camera

So I’m not sure why it makes a difference now.
Have you tried ?

Because the scene strip is overlaid, or composited, on the video.

Works fine here


Thanks for pointing me in the right direction, but now I’m getting another problem and its that the movie is too dark.
I tried using a brightness/contrast node but it did not work to well. Any Ideas?



Try RGB curves.

Here’s an example where I darkened the image a bit.
First I set the black and white points, RGB nodes are there just to show they’re not completely black and white, but sampled from the image. I then set the RGB curve influence to 0.3 to allow finer adjustment. After the setup, I used the waveform display to help bring down the white values and also the black values just a bit.
I then added another RGB curve node to adjust the midtones. It’s not necessary to use another node but easier and gives finer control.