Not saving changes to file

I’ve been using blender as a design aid to help me plan out things I’m going to build in real life. If you’re curious one of my latest renderings is here:

[video]http://youtu.be/Q7AnW0i3q9A[/video]

However, now Bender has stopped saving my changes to the file. I’ll duplicate objects, move things around, add objects and save but when I open the file again it hasn’t saved any of my changes.

I’ve encountered this problem before in things like Quark or Photoshop but none of the solutions that work there have helped me.

I’ve saved the file in a different place with a new name, appended all the objects to a new file and saved with a new name. I’ve even tried opening the file in different versions of Blender, making changes but still no good.

Is my file corrupt beyond all hope and I have to start from scratch or is there any way to fix this?

I’m, using an 27" iMac
8 gigs of ram
Mac OS X 10.6.8

The file was created in Blender 2.62

The file is attached to this post if you want to take a look at it.

If you need any other information just ask.

Thanks

Attachments

55GalTank_Furnace_2.blend (1.61 MB)

I downloaded your blend and did some changes and saved it. Upon reopening everything was where I left them. Perhaps you have the file on your machine set to read only?

Nope, I checked. I have read and write permissions…

Just on a crazy notion I downloaded the file I attached to see if, for some weird reason, uploading it changed something somehow. Nope. I still can’t save any changes to it.

I started the file over again and it’s saving fine at the moment. I don’t get it…

I’m having the same problem. Blender has stopped saving my changes. No errors from the Blender console (when launched from a Terminal window) and nothing from the standard Mac logs that indicates a problem. I can’t see any file permission issues.

I tried Save As… to a new file - still can’t save changes.
I tried opening a new file with the cube - with that I can save changes. But when I append objects from my other file, I can no longer save changes. Very frustrating.

I’m using Blender 2.65a and Mac OS X 10.8.2, 4GB RAM.

I discovered a link between this problem and a particular object characteristic. It turns out that the only objects I was having trouble saving the changes for had an ‘animation’ action associated with it. When I selected the object, the position and rotation coordinates were highlighted with a pale yellow color:


If I right-clicked on the Animation item for the object and selected ‘Unlink Action’, the position and rotation coordinates were no longer highlighted, and I was now able to save changes for those objects:


Seems like a bug to me.