Not sure how to get transparency working (Cycles)

I have a plane with a png on it that has transparency, but instead the transparent areas are displayed as black. I’m not really sure what to do about it, I’ve been looking around the interface for 2 hours trying to figure out how to get it working.

Here’s what it looks like:


The black areas on the plane perpendicular to the floor should be transparent.

I’m a bit tired right now, so my explanation may be lacking, apologies if so.
ss13.blend (724 KB)

You haven’t included the texture in your blend file. Please pack your textures in the future.

Feed the texture into a Diffuse shader and use a Mix Shader to combine with a Transparent shader using the texture alpha channel as the mix factor

Thank you very much for your help, it’s working.
However, another ‘problem’ has arisen:
https://i.minus.com/ibwvNvsDEZUDvw.png
As you can see, there’s a blur around the character here. Normally, this might be a desired effect, but in this case I’m trying to get a sharp, pixelated image. For the floor texture, I used a node group called ‘PixelateUV’, which was posted on these forums and worked well.
I tried using texture coordinate’s generated output instead, but there are still some problems, as you can see here:
https://i.minus.com/ibqfwFOZwuIR9q.png
While it’s less blurry, it’s still not as sharp as I want. I’m not really sure where to go from here, and any more help would be hugely appreciated!
Hopefully this blend file has the textures packed into it this time.
ss13.blend (734 KB)

Your problem is this: the image you are using is tiny – 32 pixels X 32 pixels. Small images can be scaled up, but they start to look awful. You can use sharpen filters to help a tiny bit, but in reality you need a higher resolution image of the character. The rule of thumb is that the image should be twice as large as you will render it at. So if you want to render the character at about 3 inches on screen, then the image should be (3 x 2 x 72) or approximately 432 pixels by 432 pixels. In general blender will like it if you stick to powers of 2, so 512 px x 512 px. Good luck, great start!

Here is a similar character at 256 x 256, (and with a area light)
ss13-mod.blend (800 KB)

Isn’t there a way to disable antialiasing or force something like a “nearest neighbor scaling mode” for a texture?

Thanks for your help, guys.
Here’s my first render with blender, it’s not much, but I’m happy with it!
https://i.minus.com/ibo4W9ZAEmDaQz.png

Also, I suppose I’ll put this here as it may help some on a google search.