Not sure of the technical terms but I need help with something

Basically, what’s happened is this… I made a self-contained Mars habitat and the outer walls were made of 6cm thick aluminium. After some more research I learned that 6cm was far too thick, so I reduced it to 3cm thick.

Now when I render it out I’ve got really ugly black lines appering on the surface, as if the inner side of the wall segment (3cm behind the outer side from the camera’s POV) is showing through towards the camera in places. See the attached screenshot (1) to see what I mean.

I’m nigh on certain this isn’t down to lighting or anything like that. I’ve had the same artifacting occur in computer games and been able to resolve it by increasing to maximum monitor resolution. Also, when I lower the camera in Blender below a certain height the problem resolves itself, again pointing to some kind of local z-plane resolution problem. See screenshot (2) to see how it looks when the camera is below a certain height.

Any help is greatly appreciated. I don’t mind going back to 6cm thick walls as a last resort but I’d rather keep the extra interior floor space if the problem can be solved by other means.

If it helps, the term “z-buffer” might be relevant. I’m not sure though.

Note that the two dark line shadows on the right hand side of screenshot 2 are intentional.

Attachments



Just checked in 2.5 to see if it was a problem with my Blender version but the same happens in both 2.49 and 2., although I can raise the camera higher without the problem occurring in 2.5. (Still not high enough for my aerial shot unfortunately)

Try setting the Near Clip value for your camera to a higher value. Blender sometimes has problems resolving nearly-coincident faces, and I’ve found changing the Near Clip can help.

If the faces are very close to coincident (this is relative to the overall scale of the model, which also determines camera distances), you may have to fudge your “ideal” dimensions – who’s gonna know, anyway? :smiley:

Another solution is to use the Mask modifier to make the “inside” faces invisible in shots like this.

Hi chipmasque.

Can I set near clip in 2.49? I can’t seem to google up anything about it.

Also, if I use the mask modifier, will that just remove anything from an object that the camera can’t currently see from it’s POV? That sounds like a good memory saver.

Masking seems to mask every face in the object, even though i’m setting vertex groups, and i can’t figure out how to set near clip, and fudging it isn’t part of my vocabulary. Who’s next? lol

Arrrgghh! slaps forehead I found the near clip. It’s labelled as Clipping Start in 2.49 and it’s tooltip suggests it’s nothing to do with the problem I was having. Thanks man, that’s it working.

I think he’s talking about “Clip Start” in the camera settings. Camera settings, sub-section “Lens”

Yep, I figured but the tooltip reads “Clip out geometry closer than this distance to the camera”. It doesn’t really imply that it’s gonna increase the local z-axis resolution somehow. Check me out with the technical terms lol

I changed it from 0.1 to 1.0, so an increase of a factor of ten, which brings it in line with the scale I’m modelling at on this one.

So this is what I’ve got now. The camera’s 2000 of whatever unit of measurement it’s using up in the air. I think that’s 200 metres with the scale I’m working at. I feel I could go higher :yes:

Attachments


Yeah, the purpose of camera clipping is so that the ray tracer does not spend unnecessary time checking for objects in the very close foreground or very distant background. But what chipmasque is saying, I think, is that for some reason or another it may help to move your clip start closer to your model. You can visualize your clipping by clicking on Display Limits under the camera options.

Well however it works out the math it’s exactly what I was looking for. If I do run across the same problem again this’ll be the first thing I try to fix it.

Now is going down to 1cm thick walls going too far? :slight_smile:

Great! This is good to know. I suppose it’s a good rule of thumb to keep your clipping tight. I suppose it makes sense that this would increase the resolution of z depth sampling.

Also, FYI, if it says 2000, that would be in Blender Units. By default, 1 BU = 1 meter, so you should actually be 2000 meters in the air. Also, you can change Blender’s dimensioning unit to meters, feet, etc. But I forget where you go to do that. You can find it on CG Cookie.

Seems changing of units is only in 2.5 and above. Might be time for me to upgrade. I’m pretty sure it means 2000 centimetres in the air. If I zoom my 3D view all the way in the smallest grid I can get to is what makes up millimetres in my scene, and I seem to remember reading somewhere that some of the fields in Blender are divided by 10 for practical reasons. It looks about right though. If I put the camera inside the hab it looks like a pretty realistic perspective.

Well… turns out I was actually modelling too big. This guy’s head is 2 metres wide!! :eek:

Hope I don’t lose any detail by going Shift+C, A, S, 0.1

Edit: Looks like the detail has held up under shrinkage, and now I can set absolute values for all my bevels.

Attachments


Sorry about the wrong label for Clip Start – the ol’ gray cells aren’t what they use to be :rolleyes: And I have no idea why it (sometimes) works, I just found out about it while trying to deal with a similar problem involving close-fitting clothing on a figure. Can’t say it’ll always be effective, though.

The Mask modifier works kind of counter-intuitively – IIRC it masks everything except the designated vertex group. So select the vertices you want hidden, then do Invert and add the resulting selection to the designated vertex group. When you enable Mask, the verts NOT in that group should be hidden in both the UI & renderer (if so enabled, that is). OR you can select the verts you want to disappear, and use the Inverse button in the modifier pane, for the same result.