not sure this should be here but...

doing a tracking project.
things seem to be working until I hit render. at which point it shows the picture (jpg) that is part of the series I am using as the tracking background. but not the model.
both camera & model are on the same plane.
when i select the camera & hit ctrl+ 0 & play i can see the model & movie background play as it shold.
However the model is not rendering when I hit render.
stumped

More detail required. Perhaps a screen shot of your compositor setup too.

Select the render layer properties and make sure that the layers which are visible in the scene are also renderable on the render layer itself. Otherwise you get all sorts of things happening at render time while nothing renders.

I have everything on one layer. my nodes were a lot busier but tried to pare it down.
Added a simple cube.
still not rendering.
[ATTACH=CONFIG]272964[/ATTACH]


You need an alpha over node to add the 3D element to the background image. The compositor output isn’t meant to be a mixing device.

3point Thank you very much and especially for the explantory screenshot will go try it out.
D

ok will keep working on this, have the correct nodes in (looks like) but still not showing up. [ATTACH=CONFIG]273015[/ATTACH]

And while I was looking for ways to fix this went to movie clip editor saw that along w/the movie clip I have a jpg the vide output. when i delete that I get the object but no longer the background image.
sorry realize all this sound a bit stupid. i started this a while back, put it hold and finally had some time to come back to it.
[ATTACH=CONFIG]273046[/ATTACH]
Feel like I might have to start from scratch…

It’s not stupid at all, Blender has so many functions packed into it that even the pros get lost now and then. Is there some reason why you’re using the compositor and the sequence editor at the same time? Render Properties buttons>Post Processing tab>Sequencer check-box. Disable that check-box and you should get a good preview when you re-render. Make sure that the compositing check-box IS enabled. Blender is designed so that you can use both but in your case there is no need to do this.

Rambo thank you for your help and kind words! I will go try that out.
as for me using both the compositor & sequence i was just trying to figure out what i could poke at to make things work. Am also trying to get more into cycles
Thanks crossing fingers that’ll work!

yes!!! Score! OMG! that worked, yet one more item to add to my list of things/people/places to be grateful for.
so have to ask what is “sequencer” for? except making things hard?

one more question right now I have the alpha over at premul:0 & fac:0.5 the composite node is at alpha :1 z1
the result is that the model looks a bit ghostly & it looks like it is covered by the clouds. Like it was a layer below.
i will look up masks tutorials to see if I can use that. But any advice on how to make the model stick out better?
thx
D

Sequencer is more of a traditional video editor. Lots of people around here love it but I cut my teeth on After Effects & Premier Pro and find the VSE to be crude, clunky and hard to get along with. I never go anywhere near it because VSE isn’t capable of anything that the Compositor isn’t (you just might have to work a little harder in the compositor sometimes) although the inverse isn’t even close to being true, but to each his own.

Sometimes you’ll notice a darker or lighter halo directly around the edges of a layer that you just alpha’d over another image…that premul button usually solves the problem. It’s a good idea to take a primer on alpha channels:

Tip: NEVER create images with premultiplied alphas, always make them straight.

And…the final result so far!

Ed Woods would be proud. Happy i got it done. Next one will be better.