not the whole texture showing in texture-mode

Hello,
I just tried to apply a bark texture to a tree I’m modelling,
but not the whole texture is shown when I switch to texture-mode.
I’ve attached the .blend file and hope that someone can help…
Nepomuk

Attachments

Ahorn1.blend (452 KB)

It’s much more useful if you actually include textures in your blend file (File / External Data menu)

Check your mesh, you have some faces inside the mesh where the branches join the trunk

Basic steps for adding textures
UV unwarp the object
Add a material to your object
Add a a texture to the material, set to influence colour
Set the texture mapping to UV

For the viewport set it to textures and in the properties panel (N) under display set the shading to GLSL

Thank you so much!

Now I have another problem:
I try to make leaves for the tree. They are shown in texture mode,
but when I hit “p”, the texture is only shown on one side of the plane with the texture.
I also tried it with UV-Mapping instead, but it didn’t work.
/Nepomuk

Attachments

Ahorn1.blend (557 KB)

I already found a way to solve this problem:
I duplicated the plane with the texture and mirrored it around the z-axis.
Now I have the texture on both sides of the plane (now I have 2 …)