Not vertex snapping?

For some reason, vertex snapping is not working at all. Whether I enable it, or use control to use it, it just does nothing.

Here is my .blend file. http://www.pasteall.org/blend/42340

Enable “snap onto itself” and you won’t have this problem anymore. Are you sure you have it enabled, press Shift+Tab and see if it’s cycling ON and OFF for that tool?