Nothing I download works in my Linux.

I have Linux Feodra Core 4, and I downlaoded several games and apps, and one of them worked. The others ask for stuff I already installed.

[[email protected] sauerbraten]# ./sauerbraten_unix
./bin_unix/linux_client: error while loading shared libraries: libSDL_image-1.2.so.0: cannot open shared object file: No such file or directory

Also, I’ve tried to install Unreal Tournament and Quake and it didn’t work, even though it worked before on the same OS.

Don’t you mean “even though they worked on windows”?

AFAIK, the only way to play the majority of “windows made” games on linux is through wine, or some other windows API emulation.

Did you ask on the Fedora forums?

I have Quake: The Offering, which is the original Quake, with two expansion packs, that is for Linux. And on the Unreal Tournament CD case it says on the back that it works on Linux, with an installer.

I’m not as noob as you might think.:slight_smile:

try installing SDL. the easiest way to do this is to use whatever packagemanager you have and search for “SDL” or “libSDL”

that would solve your problem for sauerbraten.

Post the other error messages for more solutions = )

I did, latest version. Sorry, forgot to say that.

Yeah, I was about to suggest that. (The following instructions assume as little knowledge as I can) Assuming a relatively standard fedora install, open the teminal and type:


su

enter your root password, then try


yum search sdl

That (I think) should give you a list of any sdl packages.

EDIT:

Hmmm… I’ll go look to see if there’s some sort of sdl_image package or something you might need but not have.

EDIT2: Yep, there is a sdl_image packege. When I tried the Saub. version I happened t ohave lying around, Igot a seg fault, so I can’t tell you if you’d still be getting that error if you had sdl_image.

Did you install SDL_image as well as SDL? It’s a seperate package to the standard SDL installation.

The shared object should be in your /usr/lib or /usr/local/lib directory (/usr/lib/libSDL_image-1.2.so.0.1.3 or similar) . If you have installed SDL_image ver.1.2 or later and it’s in a different location then you can symbolically link the library there to get it running. (ln -s <path to libSDL_image.so> /usr/lib/libSDL_image-1.2.so.0)

Sorry if I’m covering old ground there. Hope that helps.

Yes, my dad implied that I might need to link some files, but there are quite a few files to link.

first of all: why the hell are you starting a game as root???

to install quake3 and ut goto http://liflg.org/?catid=6 and get the reqired loki_installer. (you must execute this one as root, not the game!)

if you don´t get it to work try
ldd /usr/local/ut/ut
and have a look at the output about missing files or post it here if you need assistance

in case of your sauerbraten install you are missing sdl-image which is a seperate package from sdl

sorry to correct your dad: no need to link anything, the links are done automagically :wink:

cheers krizu