Now I'm mad...


(wewa_juicyb) #1

Okey so basicly I has this 700mhz PC overclocked to 785 and an ATI Rage 128 gfx card right it’s got 32mb and works quite well (not to mention 356mb sdram, or something like that)? Well I downloaded NeverWinter Nights and it said that my gfx driver didn’t support OpenGL so I was like “%^&#$!^” (<—F*CK). then I think, “Hey maybe I should check for new drivers”. 30min later the new driver is installed and I’m all happy cause now the game runs at a clean 30fps.
This is where Blender comes in.
I got bored of the game after 3hours of play so I decided to open Blender and blend some. BLENDER doesn’t OPEN!?!?!? But I kept my calm and restarted and now it works. But the thing is, it’s SLOW! Like REALLY S-L-O-W. I tried rendering something and it goes like 4x slower (no joke) and ontop of that all the 2d stuff in blender (think GUI) takes AGES to load/display. When I click on “File” it takes takes out timer 3.78 seconds to load the menu, I can go up and down what will be the menu 7 times in that time… do have any idea how slow that is?! that’s like rendering a 10poly scene with a 512spot+shadow…
So I was wondering does anybody know what is going on here?! and ofcourse do you have a solution? Before I forget, before I installed this “better” driver Blender was running fine like it should, menu’s were actually visible when you click on them etc.
Oh, and basicly what it boils down to (or so I believe) is that Blender doesn’t like OpenGL.

WeWa

P.S>Take a look if you don’t believe what I said about OpenGL:
Reference:
http://mirror.ati.com/support/products/pc/rage128pro/winxp/rage128prowinxpdrivers.html?cboOS=Windows+XP&cboProducts=RAGE+128+PRO&cmdNext=GO!


(SGT Squeaks) #2

downloaded? as in off the internet? as in Pirated? this may be your problem. :smiley:


(wewa_juicyb) #3

…my problem… most things that happen to me are my problem, I just feel like sharing this one :wink: 'cause a solution to a problem usually makes the world a better place (unless it creates more problems…).

WeWa

P.S> I did download the game off the internet but I played it like 3hours and decided that it wasn’t worth buying (/me looks at the zillions of games he has already bought).

P.S2> lets not change this into an ethics topic…


(kattkieru) #4

Have you tried updating your OpenGL drivers? There was some package that updates OpenGL drivers for every windows video card under the sun… Can’t remember the exact name, but a search on BluesNews.com would turn it up.


(Jamesk) #5

Well, I don’t really know what’s going on, but I’ve been there too. First of all, Blender sure likes OpenGL. It’s in fact the only thing it’s really fond of. Some systems though, like mine, is not very fond of DirectX and OpenGL being live at the same time. In some cases you have to disable all DX-functionality in order to get OpenGL apps to run as they should. It’s really weird, but starts to be a well known fact. Hell knows why this happens.

The best thing for Blender seems to be really old drivers. At least on Win2K/XP. It really sucks.

I once installed some new detonator driver for my TNT-card, and before reboot Blender ran very well, in fact faster than ever before. However, after having rebooted my box would just freeze up totally if I tried to start Blender - so, back to the really old drivers…

Someone somewhere once said that it might have to do with the automatic “repair” system in W2K/XP that checks all system files while booting, and that this would cause some newly installed drivers to have some of their files replaced by other ones that W2K decides are more “compatible”. Apparently there should be a way to disable this function, but I haven’t dug any deeper into it…


(harkyman) #6

Something else you may want to check. If your new OpenGL settings via the new drivers support full screen antialiasing, this could be your problem. Turn it off. Also check out the settings, make sure they are maximized for performance, not quality (there may even be a performance/quality slider or preset in your particular implementation.)


(Dittohead) #7

where did you download neverwinter nights anyways???

http://www.mektek.net/forums/html/emoticons/cwm13.gif


(wewa_juicyb) #8

Well what can I say… According to the info I gathered at the OpenGL page (OpenGl, or some branch of it, was originally sponsored by ATI) compat with ATI-Rage card is supposed to be the best, as in when ATI sponsored OpenGL there best card was the Rage so I assume this to be so. As to OpenGL drivers, according to the www.opengl.org site I should already have those cause the driver come with them, there is no other way of aquiring them. I had/have OpenGL performance all the way up and quality off (Fuzzy and not Sharp) I also noticed that Direct3D settings don’t affect the problem. I agree though that Blender will not work without OpenGL cause my brother has a 2.4ghz PC with a 4mb gfx card that doesn’t support OpenGL (duh) and Blender doesn’t run on that PC, some error message.
I did/do have Anti-aliasing off.

where did you download neverwinter nights anyways???

Well… <ultra secret encryption> )[email protected]#$vfds%^n&*@ASx#)[email protected]#$^KaZaAY(FBJKV%^($BV </ultra secret encryption>. Got that? DAMNIT!!! how do you do the moving little faces?!

WeWa


(Dittohead) #9

i’ll tell you where i got that emoticon, if you tell me where you got neverwinter nights.

lemme guess warez???


(sofort99) #10

I have XP and the 128 card. And I had the same trouble. What fixed it for me is that I had to uninstall and reinstall it a couple of times before it “took”. I can’t prove it but I think it is some kind of XP install bug.
And you have to make sure you have all the card drivers removed before you try to upgrade an ATI card.

Hope this helps.


(wewa_juicyb) #11

NOOOOOO!!! I can’t see how many posts I’ve made!!! NOOOO! life is now meaningless. the end of the world must be near…
sofort - I’m not sure I quite understand what you mean… Un/Reinstall XP or the drivers? And as to uninstalling the old drivers before installing the new ones, that’s quite impossible I think, you see when i uninstall the drivers it will automatically redetect better drivers and install them without asking me… As to reinstalling XP… that’s so much work…
Dittohead - Magicians became famous because they never revealed there secrets, mayeb oneday we’ll both be famous http://www.mektek.net/forums/html/emoticons/cwm13.gif <— did it work?


(sofort99) #12

From the release notes (Always some good reading!)

http://download.ati.com:80/drivers/wxpr1286133279.html

C) PRIOR to USING WXP_R128_6_13_3279.exe

Be sure to UNINSTALL any previous version of the RAGE 128 / RAGE128 PRO display driver prior to installing this
version. See the “Un-Install” section for instructions.

E) UN-INSTALL

To un-install this software;

 Click START, go to SETTINGS and select CONTROL PANEL.  
 Launch ADD/REMOVE programs. 
 Select "ATI Display Driver" and then click the ADD/REMOVE      button.  
 RESTART Windows. 

To un-install temporary files from the DOWNLOAD bundle;

 Delete the directory C:\ATI\support\WXP_R128_6_13_3279\ 

NOTE: If you unbundled the files into a different directory, simply delete that directory.

F) ISSUES YOU MAY ENCOUNTER:

CONFIRM FILE REPLACE in Windows XP.

When installing Display Drivers or Software a “Confirm File Replace” message may appear multiple times during the installation.

If you encounter a “Confirm File Replace” message while installing this display driver select the “YES” option to proceed.

Selecting “YES” will ensure that all the components of this driver bundle will replace your existing driver components.


(wewa_juicyb) #13

Well I just tried a nice little restart without drivers. And I can tell you, it is REALLY hard to stop windows from auto-installing the ATI driver that comes with windows. I start win without any 3ddriver installed and after about 30sec it informs me that it has installed an ati-rage driver on my PC… not good. So there is no way that I can install the new drivers without the old one being installed. edit coming gonna try to ctrl-alt-del and catch the little prgm that auto-installs :D.


(haunt_house) #14

hey, I can do this too
http://www.people.freenet.de/haunt_house/download/icon_maul.gifhttp://www.mektek.net/forums/html/emoticons/cwm13.gifhttp://www.people.freenet.de/haunt_house/download/icon_emperor.gif

Now he’s got a reason to look suspicious!