Numpy error when activating some addons

Hello BA. I have encountered really annoying error when activating some addons. It’s somehow related to numpy (whatever it is). I don’t install to my system numpy or other python thingies. I have windows 7 and using blender 3.0 - 3.1 with some kind of hack to make it work for windows 7. Not sure if this is can be reason for this error cause I have same error activating these scripts on blender 2.93 which don’t required windows 10. So how can I fix this issue preventing me for activating addons. Here is screenshot of error:

Here is page from error report how to troubleshoot this error. But I didn’t understood how to solve this in my case. I didn’t installed Python nor NumPy on my system. I just use blender shipped with python and numpy and I want to use addons.

https://numpy.org/devdocs/user/troubleshooting-importerror.html

P.S. I didn’t understood half words from that page. lol :smile:

What kind of hack?

Does downloading and running Blender.exe from this download one work?

https://builder.blender.org/download/daily/blender-3.2.0-candidate+v32.2d9c5f3dcf2e-windows.amd64-release.zip

I use blender 3.0 build working for windows 7 from here:

I have windows 7 and curent blender won’t install on my system unfortunately, that’s why I forced to use custom builds made blender 3.x working for windows 7. However I have blender 2.93 from blender.org it’s working fine, but I still have this annoying error preventing me activating some addons.

Please help me. :pensive:

Wait, I realized that 2.93 isn’t supporting windows 7 too, so I should try to install pre- 2.93 blender and see if it helps.

Ok. I have installed 2.83 which supports windows 7 and suddenly it worked. I managed to install addons which refused to activate on custom builds!

You should file a bug report about the issue with the developer of this package https://github.com/nalexandru/BlenderCompat, because you are not installing it through normal methods.