nvcc fatal : Value 'sm_30' is not defined for option 'gpu-architecture'

Hi,

i am fighting with my Cuda installation for days now.
First let me give you some technical-data.

Graphics card__________________GTX670
OS___________________________Xubuntu 12.4 / 32bit
Blender Version_________________2.63 r48492 built from trunk
CUDA Version__________________4.2

First i uninstalled the standard Nvidia-Drivers, and added a bunch of them to the blacklist,
in order to avoid them being reinstalled while upgrading.
After that the resolution dropped to 640x480.
After rebooting i logged in to a console (not starting XFCE)
Then i installed the CUDA Devicedrivers, and after that the Toolkit.
Everything worked fine so far.
After rebooting again (with XCFE) the resolution was back to normal again.
After updating LD_LIBRARY_PATH and PATH, i checked out the latest source with svn,
compiled it with make. There where no errors nor warnings, so the right dependencies where there.
So far so good.

Now to the Problem.
If i try to use GPU Rendering with Cycles i get:
nvcc fatal : Value ‘sm_30’ is not defined for option ‘gpu-architecture’

I have no idea where to look for this definiton.
Fist i expected to find something in Blenders Source-Code, but can’t find anything.

Can anyone point me to the right direction?
Thank’s in advance.

Hi, you can edit the CMakeLists.txt at line number 252.

set(CYCLES_CUDA_BINARIES_ARCH sm_13 sm_20 sm_21

Add sm_30 and it should compile the kernel for kepler GPU`s.
I can´t test this, it is maybe better to work with cmake-gui and change the settings there but the build process is different then.
More info here:
http://wiki.blender.org/index.php/Dev:2.5/Doc/Building_Blender/Linux/Ubuntu/CMake

Cheers, mib.

EDIT: My first idea don´t work, it is more complicated.
You could try the way from the wiki.

Thank’s.

Manual configuration with CCMake revealed that the Path for OSL_Compiler, OSL_Librarys and OSL_Includes are not found.
Apparently OSL is not pressent on my system jet.
I tried to compile it a couple of minutes ago, but ran into other missing dependencies.
Calling it a day. I’m shure i manage to compile the OSL Libs tomorow.
Keep you updated.

OSL is not used in cycles atm. and iirc it is disabled by default.

Cheers, mib.

I was hunting dependencies all day long. It was like an endless trail of missing files.
Then i stumbled upon this wiki page:

http://wiki.blender.org/index.php/Dev:2.6/Source/Render/Cycles/Building

Obviously i had to give it a try. (it was a glimpse of hope ;))
Up to the boost part everything runs clean, but i have trouble building oiio,
thus i can’t build blender either.

Now i’m a little frustrated.

Even on builds i downloaded from graphicall.org GPU rendering refuse to work.
I can set everything up in the preferences, but when it comes to rendering all i get is a black Image.
Any ideas?

Hi, did you checkout these libs in your blender-svn folder?
https://svn.blender.org/svnroot/bf-blender/trunk/lib/linux lib/linux
You get prebuild oiio, boost, ffmpeg and ocio from there.
I don´t compile these for my build system because I can´t build oiio too.
Can you see “Cuda” in your User Preferences?
Kernel building need a few minutes and there is a message about in the render window, for opencl about 10 minutes and it need a lot of RAM.
You can see the build process with “top”, nvcc and then ptax.
The most graphicall build are not suitable for kepler but the buildbot builds are 100% (I ask the blender devs for it).

Cheers, mib.
EDIT: I need a few days to get my first build done. :slight_smile:

I tried the precompiled libs, but couldn’t get a build with cycles enabled.
However i didn’t know that buildbot exist up to this day.
I downloaded the latest build, and i’m enjoying GPU rendering now!
This brought back fun to cycles.
I will probably still frickle with the code and the dependencies to gain more knowledge
about it (in the last 2 Days i learnd a lot about gcc, xubuntu and the Blender source).
But for now i let it go.
Since i still have no solution to the initial problem i didn’t mark the Thread as Solved.
If i find one i do.
Thank you again for all your help.