NVIDIA OpenGL Driver Error code: 3 (subcode 7)

Hello,
This error has plagued me for the past several months and has made blender unusable. Over the summer I upgraded my computer and ever since the upgrade I have been getting this error seemingly randomly but often. It will let me boot up blender and open a project or go through the menus, but once I have a project up with something in it, randomly, sometimes its rotating the object, moving something, applying textures, or selecting something it will just hard crash. No lag or window not responding just a hard crash with no upfront error or notice.

After checking the event viewer in windows this is what I see

(this is the first time using this forum I don’t know if this will embed or not)

Over the past few months I have attempted to resolve this error on my own and even contacted Nvidia support about it but they weren’t able to help me. I did not keep a list of things that I did in attempt to solve this issue so ill try to list most of them off from memory.

Reinstalling blender, Updating blender, downgrading blender, removing my addons, Updating Nvidia drivers, uninstalling and reinstalling the drivers, Power management mode in Nvidia control panel, Reseating the graphics card, switching to Studio Drivers, etc. (I may be forgetting some at the moment)

I was told that because of my upgrade when I went from Intel to Ryzen that that could be the issue. So I reinstalled windows and when that didn’t work I formatted my drives to and got a completely fresh install of windows. This didn’t work either.

I also hesitate to say that it could be a hardware issue because every other application I have installed works great and even stress testing the components does not cause any problems. I doubt it is the GPU because when I initially upgraded I was running on my old 1070ti but I upgraded to a 3060 later in the year both graphics cards having giving the same error on blender and nothing else.

Maybe its my lack of experience with computers but I have done extensive experimenting and I believe that I reached my limits to what else I can do. I appreciate all the help I can get at this point. If I did forget something in this initial post I’m sorry but I just couldn’t remember all the things I have tried.

Thank you.

1 Like

Hi Cliff,

Have you tried other Blender device settings like CUDA, OptiX or none? What about CPU only? Any crashes then? Are you using Win 10?

Hello, I have tried those different settings and nothing seems to work. I am running windows 10.

I have been checking my Task Manager as well to see what happens and It shows a spike in gpu usage when it crashes idk if this helps but its something.

I had to put this in a different reply because it wouldn’t let me send 2 pictures but…

as well as that I also tried rendering something with my gpu and this comes up. I dont know what this means but when I try to render with my cpu it renders fine.

Which version of Blender are you running? Also what version of the Nvidia river and what version of Windows?

The Preferences under System->Cycles Compute Devices are exactly that, the devices which Cycles should use when rendering in GPU Compute mode. They will have NO EFFECT on ANY other operation in Blender than Cycles rendering (final or Rendered Viewport). Unless it crashes when rendering don’t worry about any of those settings.

Compute Capability 8.6 is what the 30x0 cards provide, and that error suggests you’re using quite an old Blender or there’s some issue with your Blender version (like you built it yourself and didn’t compile in the Nvidia device kernels which is easy to get wrong). Try a current Blender version, and download the ZIP version, extract it somewhere like the desktop, go into the folder and inside the version directory (named 2.93, 3.0, etc.) make a new directory named config then go up a level and run the blender executable. This will ensure that Blender keeps all it configuration files separate for this specific version so there’s no chance that a broken config or add-on on your system is going to affect it. It will start with a clean default configuration.

Let us know if it’s still failing with a current Blender version.

1 Like

I get the same error every time I use Blender longer than couple of minutes. ExceptionCode : EXCEPTION_ACCESS_VIOLATION

Blender version: 3.0 but it was crashing even in 2.83 and 2.93

Please someone help, can’t use Blender for weeks.

It’s likely some external issue to the core Blender. Have you tried running with add-ons disabled? Updated all drivers (video especially), tablet drivers if applicable, etc.?

2 Likes

I tried windows formatting, updating windows, updating video graphic driver, changing driver to studĹźo mode, installing other versions of blender, using blender without addons and more. I am getting the same error all the time which is opengl driver error code 3 subcode 7

I don’t wanna spam the topic but please someone help.

:nauseated_face: :nauseated_face: :nauseated_face: Someone help us please.

What type of computer and what graphics card?

From what you’ve said though it sounds like you probably have a hardware problem of some sort, since you’ve tried pretty much everything else.

Here are my specs:

RAM 16gb ddr4 3600mhz
Storage corsair m2 ssd
Graphic Card 3060 ti
Motherboard biostar b550mh
Processor 5600x

I tried many things like updating drivers for couple times, using other versions of Blender, switching GPU with another GPU and more.

A temporary solution is to un-select the GPU in Perferences i.e. using CPU only for render.
The rendering speed will be slower but at least you can get Blender running smoothly again.

Unfortunately, that probably won’t help at all. Blender’s System settings apply ONLY to Cycles rendering and have no other effect on the behavior of the program and it sounds like he’s unable to get Blender to run at all for more than a few minutes.

If you’ve tried switching the GPU out, then I’m not sure what’s left. Are you current on the motherboard’s firmware? Have you tried a different motherboard slot for the GPU? Tried a non-Nvidia GPU? There’s not much left other than a motherboard problem or some fundamental incompatibility between the motherboard and the video cards you’ve tried.

Also, I would make sure you’re running the motherboard in its default configuration, no overclocking, no messing with voltages etc. There could still be some motherboard configuration setting that would affect it maybe.

Today I switched my RAM and Blender didn’t crash yet. I hope I fixed. Tomorrow I will try to make Blender crash if it can randomly.

1 Like

I solved the problem by changing RAM freaquency 3600 to 3000. It was really weir crash but finally solved for me. Both Blender and Halo Infinite is totally runnable at the moment.

2 Likes