NVIDIA Quadro P400 GPU not recognized by Blender since an OS change

Hello everyone,

Here is my problem : I want to configure my GPU for Cycles (a NVIDIA Quadro P400) by going to Edit → Preferences → System. This is an operation that worked very well with same machine but under Windows 10. Now that I have switched to a Linux OS (Lubuntu 20.04), Blender (v2.92) does not recognize any GPU.

So I’m wondering what the problem could be? Is it a hardware problem or that I chose the wrong OS for my configuration?

GPU is well recognized by the system, here is what I get with “screenfetch” command :

  • OS: Ubuntu 20.04 focal
  • Kernel: x86_64 Linux 5.8.0-49-generic
  • Uptime: 36m
  • Packages: 2149
  • Shell: bash 5.0.17
  • Resolution: 3120x1050
  • DE: LXQt 0.14.1
  • WM: OpenBox
  • WM Theme: Leech
  • GTK Theme: Arc-Dark [GTK2], Arc-Dark [GTK3]
  • Icon Theme: ePapirus
  • Font: Ubuntu 11
  • Disk: 131G / 912G (16%)
  • CPU: AMD FX-6300 Six-Core @ 6x 3.5GHz
  • GPU: Quadro P400
  • RAM: 2226MiB / 7944MiB

However, NVIDIA seems to be supported by the latest version of Blender as indicated here : https://developer.nvidia.com/cuda-gpus#compute ; at section “CUDA-Enabled NVIDIA Quadro and NVIDIA RTX”

Thank you in advance for your answer,

There is no proprietary drivers in Linux by default: install Nvidia driver.

I managed to install Nvidia drivers and CUDA but it still doesn’t work with Blender. The problem is slightly different, I changed OS again to test Debian. I think I’ll post another topic on the forum