Hi all, I’m having a problem with blender not detecting my nVidia TITAN GPU!
there is no GPU option in blender under user preferences.
what I did is:

-installed my nVidia driver and libraries from rpm-fusion repository using:
yum install akmod-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia-libs.i686

-checked that the driver installed cuda libraries at:

-checked that blender can use my card, which has a compute capability of 3.5 using this link:

-downloaded blender from the official website from this link:

-checked that blender has the corresponding cuda pre-compiled binaries -in my case “kernel_sm_35.cubin”- in the directory:

after this I started blender but can’t find a GPU option under user preferences!

I did some search on the internet and did some search and found out that some people got this fixed by installing the nVidia driver from the official nVidia website, although I knew that this is VERY BAD and it will eventually kill my system, but did it anyways, so what I did is:

-removed the rpmfusion driver using
yum remove akmod-nvidia* xorg-x11-drv-nvidia*

-downloaded and installed the official nVidia driver from this link:

and yes…it did kill my system and I had to boot from the fedora dvd to fix the broken xorg…
so I removed the official driver using the script that came with it and re-installed the rpmfusion driver.
I did more search and found that for fedora 19 to use cuda I have to install the cuda-toolkit, and some people also says that this helped them fix this issue with no GPU option showing in blender…
although I know that this is not the case here as blender already comes with the pre-compiled cuda binary, I did it anyway
but couldn’t find a fedora 19 version of cuda so what I did is:

-followed this guide and installed cuda 5.5:

then I started blender but still no cuda option!!
I thought that my installation of cuda is not correct so what I did is:

-removed my old cuda install

-used the second method of installing cuda by downloading and installing the cuda ysing yum package manager so I installed the cuda repository from this link:

-the I installed cuda using the following command in terminal:
yum install cuda

after the download and installation finished I opened blender and still no cuda option under user preferences!!!
I tried to reboot my machine after the install, but found out that I can’t log-in to fedora and the x-server wont start
because the cuda-toolkit from the cuda repository installed an nVidia driver for fedora 18 without even give me an option to chose from!!, anyways I booted to the install dvd again, removed the cuda toolkit and fixed the problem.
I also tried selecting the experimental option in render settings for a chance for the GPU option to show up, but NO it didn’t!
I also tried to export the nvidia lib paths by editing ~/.bash_profile and inserting
export LD_LIBRARY_PATH=/lib64/nvidia$LD_LIBRARY_PATH
with no luck!

I thought that there might be something wrong with the card so I switched to -Windows7 X64 SP1- and installed the nVidia driver and blender can see cuda and render with it!

now, can anyone show me what I’m doing wrong, or what dependency I should install for blender to be able to show the GPU option in fedora 19?
also it’s worth mentioning that with these steps and fedora 18 cuda option was showing up and rendering with no problem.

My Current PC Configuration Is:
-CPU:Intel Core I7 3930K
-MB:Asus SaberTooth-X79
-OS:Linux Fedora 19-x86_64, with Kernel 3.10.10-200

blender Version:2.68a-r60058

Fedora has alway been “proprietary driver unfriendly”. Try this guide to get the proper video drivers installed;


The guide seems a little brief to me, but once you have rebooted with the appropriate driver installed, you can open a terminal and do;

sudo lsmod

and look for nvidia in the list. If the list is very long you may want to do;

sudo lsmod | grep nvidia

If it isn’t there as a secondary check do;

sudo lsmod | grep nouveau

If nouveau is there the wrong driver is still being loaded. At the bottom of the page mentioned above is a list of Related Posts. Have a look through the older posts for a way to blacklist or remove the nouveau driver. Apparently with the newer versions of Fedora you don’t have to remove/blacklist but I am doubtful. :slight_smile:

Until you have the proprietary NVidia drivers installed you will not be able to access the CUDA capabilities of the card. Once you have the proper driver installed you won’t need the CUDA toolkit unless you want to start compiling blender. I prefer to use one of the latest versions off of http://builder.blender.org/download/

Good luck,


[joededman] <-- the proprietary driver is already installed and working fine, what I meant is that the driver at nVidia’s site is the one causing all the problems but the one packed by rpmusion is working fine, both are the same driver actually. but the one in the rpm fusion repo is installed through yum package manager.
also cuda was working fine using just this driver on fedora 18.

I finally found the solution and now blender can see my card and render fine, what I did is:

-started fedora in shell mode by running the following command:
ln -sf /lib/systemd/system/multi-user.target /etc/systemd/system/default.target

-reboot the system

-when fedora started again it started in shell mode so I removed the rpm fusion nVidia driver with the commands-
yum remove akmod-nvidia*
yum remove xorg-x11-drv-nvidia*
rm /etc/X11/xorg*

-installed the nVidia driver from the nVidia website (the one that caused the problem before)

-black-listed the default fedora GPU driver by editing the file /etc/modprob.d/blacklist.conf using the command:
kate /etc/modprobe.d/blacklist.conf
-added the line
blacklist nouveau

-started fedora again in UI mode by running the command:
ln -sf /lib/systemd/system/graphical.target /etc/systemd/system/default.target

and all is working fine now.
so the problem before with the official driver was that I forgot to blacklist the default nouveau driver so it was trying to start with the nVidia driver.
the lines to start fedora in shell or graphical modes only works on fedora 18 and 19 older version of fedora uses the file /etc/inittab
to start in shell edit that file using the command:
kate /etc/inittab
add the following line at the end of the file:
next time you start fedora it will start in shell mode.
to revert back to UI mode edit the file again and change the line to

hope that helps some people as I was struggling a lot with this.