OBJ Export troubles

i am trying to export an object, to use in another program.
i have not been able to make any use of the error log. (below)
i have come to think that the object (or tommygun im trying to export to obj) has no attributed name. an for the love of god i cant seem to figure out how to name it! the only other idea i have is that the object its refering to isnt indeed even related to the obj but related to python in some way.
either way i cant get it to work. could anyone off any guidance?


OBJ Export path: "C:\Program Files\Blender Foundation\Blender\.blender\[blender-
files]	ommy-gun.obj"
Traceback (most recent call last):
  File "<string>", line 615, in write_ui
  File "<string>", line 318, in write
  File "<string>", line 318, in <lambda>
AttributeError: 'NoneType' object has no attribute 'name' 

I’m not sure what thats asking for either, but did you have the object selected when you tried to export, and do you have Python installed?
(I think you should be able to export to .obj without PY, but with PY you can export to many more types.)

yep, but i found out, i have to simplify the meshes before i can use them.
so it doesnt really matter anymore whether i could get this to work.

I’m getting the exact same error…

What do you mean by “simplify” the mesh? I didn’t have this problem with 2.37a, but do with 2.41?

Yup, just tested it. The exact same model works fine in 2.37a and outputs an .obj without error, but in 2.41 I get the same error as Mashive.

Whats up?

… well I found a fix (at least for now): I copied the “obj_export.py” file from my 2.37a folder to my 2.41 folder and it works. None of the fancy new features or GUI of the new script, but it works.

AttributeError: ‘NoneType’ object has no attribute ‘name’

This is usually a sign of a programming error in the script. Some function or method has returned None instead of the expected object. When you try to access the name attribute of the object, you get the exception you see. Example:

foo = get_some_object() # foo is None if object not found
print foo.name # throws AttributeError