OBJ import in 2.62 errors

Hello all,

I’m testing out Blender at the moment and have downloaded today’s 2.62 build, but I’m still getting the same error when I try to import any OBJ files:

Traceback (most recent call last):
File “C:\Program Files\Blender Foundation\Blender\2.62\scripts\addons\io_scene_obj_init_.py”, line 167, in execute
return import_obj.load(self, context, **keywords)
File “C:\Program Files\Blender Foundation\Blender\2.62\scripts\addons\io_scene_obj\import_obj.py”, line 1099, in load
File “C:\Program Files\Blender Foundation\Blender\2.62\scripts\addons\io_scene_obj\import_obj.py”, line 600, in create_mesh
blender_tface = me.uv_textures[0].data[i]
IndexError: bpy_prop_collection[index]: index 0 out of range, size 0

location:<unknown location>:-1

Does anyone have a solution for this?



downloaded today’s 2.62 build

Does anyone have a solution for this?

Try the official 2.62 release rather than a recent version which has bmesh and so may potentially break scripts.

use the stable and official 2.62 version, this error also happens to me since bmesh was merged to the trunk.

I’ve tried replacing the import_obj.py from the official release and still have the issue. I wanted to use the build that had been setup to fully use CUDA.

Wow, my first post to the Blender forum and I get a snarky response. Is that par for the course with Blender people? I was hoping for a slightly more helpful/polite response.

Thanks anyway…


Ah thanks ble. That does make sense.

I appreciate it.