.obj (waveform) + materials

Hi to all friends here…

i made a little search with no result about the question i want to make…

I use the 3dstudio max to make a model.
After i save it like a .obj type of file in order to import it to the Blender.
i choose to save and the materials for this model (it is saved in a different type of file .mtl )

when i import the models in blender i can see is only as a Grey colored .

how can i make blender import and the materials - colors i saved with the object from 3studio max ??

thanks in advance

Can you make a simple cube and post the obj- and mtl-files here.

Can you try the Collada export? (Max does have this, I assume. I haven’t used Max for a very long time.) You can import using Blender’s Collada 1.4 import.
Just a suggestion.

snifix can you explain the procedure of the cube and posting inside obj-mlt files??

makr i taste the collada export thougt that worked as appeared the model with the colors inside the blender… but when i try render it… it was invisible… only the shadow-shape from light was there

thanks both for the interesting and quick answers

The obj- and mtl-files you save are in text format, so it could be possible to see what’s wrong just looking inside the files. For example here is some small objects, and their materials:


# A 2 x 2 square mapped with a 1 x 1 square
# texture stretched to fit the square exactly.
mtllib master.mtl
v 0.000000 2.000000 0.000000
v 0.000000 0.000000 0.000000
v 2.000000 0.000000 0.000000
v 2.000000 2.000000 0.000000
vt 0.000000 1.000000 0.000000
vt 0.000000 0.000000 0.000000
vt 1.000000 0.000000 0.000000
vt 1.000000 1.000000 0.000000
# 4 vertices
usemtl texture1
# The first number is the point,
# then the slash,
# and the second is the texture point
f 1/1 2/2 3/3 4/4
# 1 element


# Blender3D MTL File: dish1.blend
# Material Count: 1
newmtl texture1
Ns 0
Ka 0.000000 0.000000 0.000000
Kd 0.8 0.8 0.8
Ks 0.8 0.8 0.8
d 1
illum 2
map_Kd roadblock.jpg

As I see it, the mtl file makes reference to the texture for your object. In the example given by SnifiX, the texture is named “roadblock.jpg” Make sure this texture is in the same location as your obj and select ‘Material’ in the obj import options. The texture should then be brought into blender with the import and mapped to the UVs. This works for me when I import an obj into blender which was exported from zbrush


do you have them in the same directory so blender can find them. so you can just see 1 obj and 1 mtl file.

I doubt it. From what I remember of Max’s obj export, it creates two seperate folders for the Obj & Mtl.
So all that is to be done is to copy it to the Obj folder - like you’re probably suggesting.
(It may not be this, but it’s better to get it out of the way). Perhaps there is not enough light on the object? Or the default camera has been selected, not the camera. Or the camera is not pointed properly for some reason?

First of all - Thanks for the interesting to help me guys …

  1. studio max saved the .obj and .mtl file in the same directory… but because i had some objects at the same directory (but with different names) i try this time with a new directory containing only the .obj and .mtl files.

had the same result…

lets explain to you with some pictures what i am doing to see what i am doing wrong (i am not a pro user of this programs )

first i am building a basic model in my studio max.


and this is how it look when i render it from inside the 3ds max :


now i try to save it the selected model as a .obj :



after that i open my blender and select to import a .obj file in my scene



and i get this result always (even when i try different compilations in insert buttons) :


( i use the 3dnop script for 3d presentation…but i dont think that this is had to do anything with my problem as it makes the same when i import it in a new scene )

and here is what it look like after render it :


hope these pictures help you to find what havent understand and make wrong


Can you post the OBJ & DAE exports here (in zipped format)?

Here is how I do it. I import my 3d object into Poser Pro.
I export it as Collada.
Then I export it as OBJ into the same folder as Collada.
Then when I import it into Blender, the exported Collada maps are found by the OBJ importer.

Maybe you could do the same thing with Max? Export it twice into the same folder. Let Collada collect the maps, then the OBJ importer might find them?