Object appears BLACK after modelling -in texture mode!

Have you experienced the black box? If not, here’s the chance, see attachment!
I made a simple example by repeating the same procedure.

How can this be fixed???


xp3.blend (371 KB)

Turn off GLSL?

Change from Textured to Solid view mode or add a material to your cube and a light to your scene

Thanks, I just found out too, the light was missing on this example -sorry!

But I think I found a bug: On my working blend file I made the object on another layer and it was black because it didn’t receive light while the light existed on the first layer and while “This Layer Only” checkbox on light properties was NOT checked!
The popping info for the checkbox reads “Illuminate objects only on the same layer the lamp is on”, so since it wasn’t checked it should illuminate the 4th layer my model was on.

When I saw it was black contrary to other objects on the first layer, I thought it was a modeling bug… but it turns out it was a light-properties bug!

Another light-related bug: The Alpha value inside the material/transparency settings, affects the way the object appears and illuminates, with the material/transparency check box disabled!