Object following a path in Blender 2.67

Hello
Edit: I used Blender 2.7 and not 2.67 as mentioned in the object. sorry for that
I used in the past to have an object, like camera, following a path by selecting the camera, then the path, clicking Ctrl P, and on the popping menu selecting ‘follow path’.
Not anymore as it seem. doing that the camera disappear from the 3D view/space and also from the outliner, and a new non selectable circle made out of dots appear in the 3D space?
I have looked at the wiki but is is the old info and does not mention what is the use of the ‘evaluation time’ with decimal numbers. In the past the evaluation time was the starting frame and ending frame I guess?
Anyway I’d like to get my camera back and understand what is the proper way, now, to have an object following a path?
Also I tried to save a snapshot from the state of the project but it seems that Blender 2.67 has a problem saving snapshot? They dont show up in the folder but Blender does mention them as saved?

I tried to post the blend file on pastall.org but the site is not online!!

I use/ test Blender 2.67 Hash 10f4c62 on a pc, Ubuntu 13.10 8 gb ram, nvidia gt 6800

I could get a snapshot from the 2.69 official version.
Edit: I used Blender 2.7 and not 2.67 as I mentioned earlier… Sorry for that.

Attachments


It looks like it worked fine to me. Notice in the outliner that your camera is now the child of the BezierCircle path. This is why the camera disappeared (Camera location x BezierCircle location = Offscreen coordinate). You could still look through it, however.

Select the Camera in the outliner then move your mouse into the 3D view and press ALT-G. This will clear the location for the camera and it should jump to the start of the path.

Thanks
First time I face such a situation…
Got it back
Thanks