Object inside transparent object turns black!

I am trying to make an eye in Blender Render and I have done the following:

Render settings have ray tracing and all the other checked in shading.

Outer layer mesh
This has sclera color with veins and a hole in the middle front to show the iris. It is textured with a transparent .png and texture alpha is 1 (image set to use straight alpha), and material alpha is less than 1. It looks good in viewport and material viewer. The object is an enclosed ball mesh.
Even the object (tab) is set to transparency.

Iris mesh
This is a small disc-ish mesh placed inside the outer layer and has a regular opaque material.
Texture is set to Receive transparent.

No matter how I change the settings on the outer layer mesh, be it Ztransp or Raytransp, up or down on alpha, high or low depth number, long or short limit in raytransp, all opaque objects inside of the transparent object receives no light.

What do I do wrong? I need to use the internal render since Cycles is hellishly slow for my scenes…

Internal materials have to Receive Transparent Shadows. Look for a checkbox on Material tab.

Yes, I wrote that have already done that on both meshes :slight_smile:

“Texture is set to Receive transparent” - not quite a Material tab and mentioned checkbox…
No ideas then.
.

Sorry about that, thanks anyway :slight_smile:

Give us the Blend file, so we can check it. Usually it is one of the render settings or lighting.

I figured it out, finally!

The transparent mesh should have “Traceable” UNCHECKED! And Ztransp works better than Raytransp to let the underlaying mesh shine through :slight_smile:

If you have caustics disabled it will also cause this problem

Nah, I use blender Internal renderer, but thanks for the tip :slight_smile:

Cycles renders very good, but to get clean scenes it takes ages for animation

There’s no caustics switch in BI, true.

Could we see the eye render you have now? I’m not certain you get all what BI could offer, with these settings.