Object layer won't NOT render

My ‘Scene’ RenderLayer is made of 8 object layers. 3 of those 8 object layers have been deselected from the Scene RenderLayer because I want to composite them differently.

When I render, the Scene still renders these deselected layers.

Anyone have an idea where the ‘cross-talk’ might be coming from?

I had a node tree up and running, but even after completely tearing it down and just having one ‘Scene’ RenderLayer going directly to the Viewer and Output nodes (NO filters), these deselected object layers are still showing up.

The deselected layer contains planes used for glowing strips, which is why they’re on a separate object layer - for the glows and glares. But they’re not duplicated on the scene layer.

Blend file ?



So the problem is… ‘spillage’? Despite deselecting the stripLight layer, I can still see it on the Scene layer.

  1. The file you gave have some linked libraries.
  2. In settings of “Scene” render layer all of the layers active for the scene are also set to be rendered (“Layer:” set of layers), so why shouldn’t they be rendered? Deactivate anything, so it won’t render.

Hi Bartek, thanks for your time…

  1. I didn’t embed any image materials in the blend file to reduce size, and they’re not relevant.

  2. My problem is with RenderLayer “Scene”. It seems to be receiving a glow, or imprint, something, in the narrow vertical grooves of the vertical pillars. I’ve circled the problem below. I’ve also circled the RenderLayer that contains the green, noisy strip, and it has been deselected.

If the LightsStrip render layer has been deactivated, why is it sending information to ‘Scene’? It’s not even correctly masked: if you render this out and compare the ‘LightsStrip’ with the ‘Scene’ layer, they’re not the same: the left-most strip is way more visible in ‘Scene’ than it is in ‘LightsStrip’.

When something don’t render - it doesn’t mean that it doesn’t influence other things.
If you used Cycles, you’d have yet another set of layers: “Exclude”. There you set which layers should not influence your render.
In Blender Render when you want the object to be excluded - you have to set it not to be traceable. (Options of the material).

I would like to expand on what Bartek is saying here. Even though Blender doesn’t read this way, the wiki does: Scene Layers, Camera Layers, Exclude Layers, Mask Layers. Currently Camera Layers are marked just “Layers”. Camera layers actually makes a lot more sense.

So here is how it works. Anything you want to render must both be included in the Scene Layers and Camera Layers. When using Scene Camera and Mask Layers all together, you get a dance of being able to

  1. Scene Layers and (Camera) Layers combined - Render what you want to see

  2. Mask Layers - Separate objects like hair but still have the face cut out the hair so that when you composite them together, you don’t see the back of the hair, or where the lips might cover the mustache from an angle, or the bridge of the nose covers up the eyelashes. And then you can set another render layer to do vice versa, cutting the hair out of the head on a separate render. Why is this important to do? Well, for one I can separate SSS objects that only render on CPU and all objects that only render on GPU. Then I can set a render on 2 open Blender programs, one for CPU and one for GPU. Now I’m rendering double time that I’d normally have to wait 24 hours for a GPU animation to start the CPU render. Also, when I color correct stuff I may want to color correct the eyes only, the beard only etc. There are workarounds to this by effectively making your own black and white alpha maps that may render faster but this is the idea.

  3. (Camera) Layers - The main use of these layers are to deselect what you DON’T want the camera to see but you want the Global Illumination from the unseen objects to still affect. It is exactly like combining a transparent node to an emission object or diffuse object and connecting a camera input. The object is invisible but still effects the scene. Color spill is a natural effect and I personally don’t see why people want to eliminate it but should you want to, just turn off the Scene layer, not the (Camera) Layer or turn them both off. Turning off the Camera Layer but keeping the Scene layer just hides it from the camera but the effects are still there.

I really don’t understand the exclude options. Maybe Bartek can help with that. To me, it seems like you just don’t include that layer in the Scene Layers and you should be fine.

Thanks guys. I’m battling on, but I’m trying to stick to Blender Render and simple compositing node configurations, or my old iMac will melt :slight_smile: I appreciate the time and knowledge, cheers!