object moving on top of camera

(Dreamweaver) #1

When i switch to camera view, my main object iv’e modeled moves to the position of the camera. The eye balls which i set in his head, detach and stay where they were. So, when i go into camera view all i see is the inside of my model’s head. When i go to front view his eyes are a few feet behind his head. (By the way, i put the body of my model in layer 1 and just the eyes in layer 2.) I am attempting to change the camera while all layers are selected. Also, i saved my project before this happened so i can still go back. Any ideas why this is happening?
EDIT I’m following the tutorial called BSoD/Introduction to Charactor Animation from the blender wiki

EDIT I added a few screenshots a few posts down.

(CD38) #2

You may have accidentally made your head, or something inside it, into the camera. Try pressing the Home key so you can see everything, select the real camera, and do Ctrl-Numpad-zero. I’m not sure about the jumping eyes. It’s hard to picture from your description. Could you post a screen-shot?

(Dreamweaver) #3

hehe, ive never tried to post a screenshot before. Dont really know how, or where to host the picture. But anyways, i have 3 objects in my project, a humanoid body( Which is acting as if it WAS the camera) and 2 eyes, which are both separate objects. When i zoom away from the my model and hit Ctrl+Alt+num0 , just the body moves to this point instead of the camera. The 2 eyes simply stay where they were. Ive tried selecting the camera and doing NUM 0 . I really need to figure out how to post my screen shots, sry.

(CD38) #4

I use www.imageshack.us. Upload your file (browse for its location, then use the Host it! button). Copy the entire link that’s labelled Thumbnails for Forums (1) into your forum posting.

Oh and in Blender you can use Ctrl-F3 to save a window to a jpg file, or Ctrl-Shift-F3 to save the whole screen.

(Dreamweaver) #5

Ok here are my screen shots ( i hope…)

First one shows my model with camera selected off to the right.
http://img157.imageshack.us/img157/7606/pic11qf3.th.jpg

The next screenshot shows what happens when i hit Ctrl+Alt+NUM0 (This view is inside my character’s head)
http://img157.imageshack.us/img157/4025/pic131hb8.th.jpg

and the last shot shows when i zoom out and up a little, so you can see that the camera has not moved, the eyes are where they were origionally,
but the body is now where the camera should have been repositioned to…
http://img95.imageshack.us/img95/878/pic12ct5.th.jpg

  • Thank you CD38 for providing me with the link and info for posting my screenshots!
(alexedwin) #6

Hi

I glad I’m not the only one!:rolleyes:
It’s driving me nuts!:mad:

I am following the tutorial to the letter! (I think?)

Alex

(lexi) #7

the camera actually dont move with Ctrl+Alt+NUM0 you just look thru the camera in a viewport so camera stays in place and for the third screenshot i think you tried zooming with scroll wheel but insted pressed maybe accidentially the middelmousbutton and you got the custom view.

(CD38) #8

the camera actually dont move with Ctrl+Alt+NUM0

Actually the camera does move with this command, see below.

@dreamweaver : I’m pretty sure you made the body into the camera at some point with an accidental Ctrl-zero when it was selected. You need to be careful with those Numpad-zero commands. Here they are:

zero alone: changes the viewport so you’re looking through the active camera. (“I wonder what the camera’s seeing?”)
Ctrl-alt-zero: moves the camera to match the current 3D viewport. (“I like this angle; let’s put the camera here.”) This is why your humanoid is jumping around and looking inside itself. Very mind-bending.
Ctrl-zero : makes the selected object into the active camera. Anything can be a “camera.” In this case it’s your humanoid object. This is poorly documented and seems to cause all kinds of grief because it’s an easy misstep.

Select the real camera with the RMB and do Ctrl-zero and all should be well. Since other people are having this problem with the tute I suspect there’s a typo in it somewhere. I’ll look through it when I get a chance.

Edit: The camera section of the tute is fine. It’s really easy to leave the Alt out of that clumsy Ctrl-Alt-Numpad-0 though and get into your situation. I’ll pm Ryan and see if he will add this information.

(marenzelleria) #9

Thanks CD38, I added a note addressing this issue:
(http://mediawiki.blender.org/index.php/BSoD/Introduction_to_Character_Animation/Lighting#Add_a_camera

-Ryan

(Dreamweaver) #10

Thank you so much CD38! It’s all fixed now. Your right, i must have accidentally hit Ctrl+NUM0 by accident somewhere along the way. I think the Tut was correct about the correct key-commands, but maybe a caution note about the Ctrl+NUM0 command would be a helpful addition. Thanks again.:slight_smile:

EDIT just noticed you posted before me…Thanks Ryan.