Object no longer controlled by armature in game engine?

I have done some playing with the game engine in the past, but have never figured out how to make things animate. I have the character’s mesh with an armature modifier, I have an animation to play, I have the armature logic bricks set up. I have also tried parenting the armature to the character several times.

However, every time I start the game engine, my character returns to his base pose (T-position as he was modeled in) Like the armature is not even affecting him. What could I be doing wrong?

I’ve looked all through this and other forums and seen several people with similar problems, but none of those fixes has worked for me. It’s getting really frustrating.

Thanks in advance.

Check this:
a) You must parent mesh to armature (not conversely), so if you grab an armature and move it, all parented objects will move along.

b) Animations (IPOs or Actions) logic bricks must be added to armature, not the mesh.

Try to search some game demos in forum to understand.

Hope I helped ;).

Thank you for the quick reply, but neither of those had any effect.

I have tried downloading games and demos, but they all seem to crash Blender if I try to right-click and select the character to figure out what was done.

(it seems that your computer is very slow)

OK. Try this:

  1. Add simple cube.
  2. Add an armature to the center of cube.
  3. Select Cube – press left shift and click on the armature with right mouse button – release shift button.
  • now you should have the two objects selected and armature is set as parent object
  1. press CTRL+P – select armature – select Name Groups
  • now the Cube is parented to armature
  1. select cube and press F9 (Editing buttons)
  2. enter Edit Mode and select all vertices
  3. see the Editing Panel – there is Vetrex Groups feature. There is only one vertex group now “bone”. Click the Assign button.
  • now the mesh Cube can be modified by Armature
  1. select armature and press “I” key and click “Loc”
  2. rise frames to 51 (or simply press up button 4 times)
  3. move the armature to any location and press “I” key again and click “Loc”
  • now you have animation, in which your mesh Cube (and the armature) will alocate from point A to point B for 50 frames
  1. select armature and press F4 (Logic Buttons Panel)
  2. add sensor Always – add controller AND – add actuator IPO and bind it al together
    sensor --------------controller ----------------- actuator
  3. in the IPO actuator: change “Play” to “Loop End”; set “Sta:” to 1 and “End:” to 51
  4. press P key in 3D window to start a game.
  • you should now see animated Cube

This is basic procedure.

Alright thank you, I got that to work. My computers definitely not slow, I don’t know why Blender would crash.

So the problem wound up being with the way I was parenting, I guess. I hadn’t clicked ‘name vertex groups.’ For a second you had me worried I’d have to put all my actions into the ipo timeline! That would have been a hassle.

But I tested it, and sure enough when I say ‘name vertex groups’ it works just fine. Thanks a lot!

Ok. I am glad it helped.