Object properties, show all edges as default?

I am constantly frustrated that I can not set a mesh to have all it´s wireframes showing in object properties viewport display, this doesn´t work by just activating the active overlays wireframe, at least not for when you extract a mesh part from a mask when sculpting, then I need to go to object properties and show edges, can´t see anywhere in the preferences to set that, and saving out a default scene isn´t possible, unless having the darn cube active.

Suggestions?

Found solution sort of, not to set the show all edges, but I missed that you can set wireframe in active overlay to be 1 for all wires showing.