Object Refusing to be Sculpted

I didn’t see a sculpting category, so I’m posting this here. I also posted this in r/Blender to see if I can get any answers at all, as I haven’t come across anyone else with this issue.

I’ve tried resetting the translation, rotation, and scale of the object, resetting the brushes, etc, but only a few of the sculpting tools will work on my mesh. I’m not sure what’s going on with it.

I tried making it more dense via subdivision and the solidify modifiers, and checked the dynotopo box, but that didn’t work either.

I can sculpt on other objects in the scene and can sculpt in new scenes, so I know the brushes work. Is there anything else I can try?

I’m using 2.91 and can upload the file if you want to check it out.

The brushes will do something if I have “auto smooth” turned all the way up on them, but they won’t do their intended function (inflate does not inflate, layer does not create a layer). None of the other settings seem to make a difference though.

I also tried exporting the object to a new scene on its own and it still has the same issues in the new file as it did in the original, even if the object had been exported as an .obj

I solved the issue by deleting the “inside” of the object and just switching over to the solidify modifier effect on flat faces. Now, when the subdivision modifier is applied, all the sculpting tools work as intended.